Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-22-2009, 07:39 PM   #1
Senior Member
mulanrouge's Avatar

Join Date: Jun 2009
Location: Westchester, NY
Photos: Gallery
Posts: 132
WTF? K100D now refuses to recognize non-DA lenses.

WTF?

So I break it out to try a new-to-me M 50mm/1.7 I just got in the mail, and there's no Shake Reduction screen. Dial's on M and switch is on MF. No longer works with the FA 80-200, either. Flash won't pop up for these aforementioned lenses or my other manual lenses.. Battery meter's full, and I also swapped them out, too, to no avail.

Works fine with the DA 18-55 and 50-200 lenses.

Any suggestions? Please and thank you.

09-22-2009, 09:10 PM   #2
Senior Member
sagiboy's Avatar

Join Date: Aug 2009
Location: LI
Posts: 230
You have to allow the aperture ring

You may want to clean all the contacts with alcohol or spirit. It could be a dirty contact. Try to change the battery and rest the camera before mounting the lens. Try to move the aperture on the lens before mounting- to make sure its not stuck.

Go to the menu and scroll down to the option of "Using aperture ring' and select 'Permitted'(thats all my *ist DL needs). After that you will be able to focus the lens manually and after u confirm the focus, set the shutter speed and expsr accordingly- works like a charm. Also you will have to set the SR manually when you mount the lens ( if you have a K100D Super)..

Hope it helps..
09-22-2009, 09:24 PM   #3
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
That's right.
You do need to ensure the K100D is set to allow non-A lenses to be used by switching the 'Using aperture ring' menu item from 'not permitted' to 'permitted'.

Then the SR screen asking you for focal length will show up and you should be able to use the lens in M mode with the green button to stop down thereafter.
09-22-2009, 09:54 PM   #4
Senior Member
mulanrouge's Avatar

Join Date: Jun 2009
Location: Westchester, NY
Photos: Gallery
Posts: 132
Original Poster
Thanks. Will try it once I get some alcohol. But what about the FA 80-200?

09-22-2009, 10:00 PM   #5
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Might seem basic but did you turn the camera off before changing lenses? You always should. I'd take the batteries out and then clean the contacts. That could easily cause an issue with the FA. Once it's clean, then mount the lens, install the battery and turn it on.
09-22-2009, 10:37 PM   #6
Senior Member
mulanrouge's Avatar

Join Date: Jun 2009
Location: Westchester, NY
Photos: Gallery
Posts: 132
Original Poster
Always do.
09-22-2009, 10:39 PM   #7
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
Don't know why it's happening with your FA lens.
Move the camera back to Av mode or even full-auto mode and see if things return to normal...
09-23-2009, 05:52 AM   #8
Senior Member
mulanrouge's Avatar

Join Date: Jun 2009
Location: Westchester, NY
Photos: Gallery
Posts: 132
Original Poster
The camera, much like myself, feels better with a little alcohol. Thanks, all!

09-23-2009, 09:19 AM   #9
Senior Member
kibipod's Avatar

Join Date: Oct 2008
Location: Ohio
Posts: 276
I guess by now you got your alcohol
So were you able to use the M lens by changing the setting?
09-23-2009, 12:44 PM   #10
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Also, keep in mind that if you accidentally move the aperture ring of an FA lens off the "A" position, for all intents and purposes, it is now a manual lens as far as the camera is concerned when it comes to exposure. It will still do AF and communication focal length, but you'd still need to have Allow Aperture Ring turned on, and do the whole stop-down metering procedure as explained in the sticky thread in this forum on using manual lenses.
09-23-2009, 10:09 PM   #11
Senior Member
mulanrouge's Avatar

Join Date: Jun 2009
Location: Westchester, NY
Photos: Gallery
Posts: 132
Original Poster
The alcohol did it. The settings were correct (and I hadn't changed them- I've used manual lenses before). Don't think the aperture ring was an issue, since I hadn't moved it, either, and then it worked after the cleaning.

Magic potion. I should use alcohol more often.
09-28-2009, 01:03 PM   #12
Veteran Member
GerryL's Avatar

Join Date: Jan 2009
Location: CA
Posts: 2,731
QuoteOriginally posted by transfergirl Quote
The camera, much like myself, feels better with a little alcohol. Thanks, all!
The answer was already here that she fixed the problem.
Everything seems to be good with alcohol.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lenses, lenses., pentax help, photography, wtf
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K7 does not recognize Sigma lens (sometimes) ulrich Pentax DSLR Discussion 15 08-29-2010 05:01 AM
K-7 Doesn't Recognize the 18-55mm WR Kit Lens cbaytan Pentax DSLR Discussion 17 03-09-2010 10:50 PM
Won't recognize PEF nezvanova Digital Processing, Software, and Printing 5 06-15-2009 05:17 PM
Anyone recognize anything in this photo of Pentax gear? Timarete Pentax Film SLR Discussion 32 04-30-2009 06:53 PM
My K10D doesn't recognize my SD card anymore Slowpoke Rodriguez Pentax Camera and Field Accessories 5 11-08-2008 05:32 PM



All times are GMT -7. The time now is 07:37 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top