Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-04-2009, 02:30 PM   #1
New Member




Join Date: Dec 2009
Posts: 7
Teleconverter and K2000

Please forgive me if I posted this in the wrong area.

Today I got through the post a teleconverter. I thought it might be a useful little beastie before I start thinking about splashing out more big cash for lenses.

I fitted it to my K2000 and one of the kit lenses, set the dial to manual and... nothing!

In the viewfinder and on the LCD, I get a flashing "F - - -" notification. If I try to use any other setting, it seems to default to AV.

Has anyone got any idea what I might be doing incorrectly and how I might remedy it?

Thanks in advance!

Adam B


Last edited by War Machine 2112; 12-04-2009 at 02:30 PM. Reason: Terrible punctuation. Sorry!
12-04-2009, 04:00 PM   #2
Veteran Member
AndrewG NY's Avatar

Join Date: Dec 2006
Location: Chappaqua, NY
Photos: Gallery
Posts: 676
What teleconverter? Does it have all the 'KA' mount contacts?
12-04-2009, 04:14 PM   #3
Pentaxian




Join Date: Feb 2009
Location: Alameda, CA
Posts: 3,194
Without knowing the TC you have, I try to answer your question in general.

- TC without electrical contacts can be used only with lens that has aperture ring. The lens's aperture ring has to be NOT set at A (if that setting is available). Camera body has to be in M mode and has option "Using aperture ring" set to "Permitted" (K10D, your camera body may have different wordings). Metering has to be "stop-down" mode (green button for K10D).

- TC with 7 electrical contacts can be used with any lens. The actual aperture is the displayed aperture X TC magnification (e.g. for 1.4X TC, actual aperture is 5.6 if displayed aperture is 4).

- TC with 6 electrical contacts can be used with any lens, but you have to make sure the 7th contact is grounded. Some TC has the mating surface with the camera painted black, thus insulating the 7th contact. In this case, you'll need to scrape the paint off so that the 7th contact is grounded.
12-04-2009, 06:04 PM   #4
New Member




Join Date: Dec 2009
Posts: 7
Original Poster
Thank you for your help. I'll look at the beastie again in the morning. Thanks for sharing your knowledge!

12-05-2009, 01:12 PM   #5
New Member




Join Date: Dec 2009
Posts: 7
Original Poster
The key to getting the beastie to work was in the settings. Allowing manual settings did the trick.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k2000, lenses, pentax help, photography, teleconverter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K2000 NR WillCarney Pentax DSLR Discussion 1 01-26-2010 02:53 AM
K2000 Duane Pentax DSLR Discussion 6 12-20-2009 05:28 PM
For Sale - Sold: Tamron 1.4x Pz-AF MC4 Teleconverter & Quantaray 2x Teleconverter DaveInPA Sold Items 15 09-24-2009 06:28 AM
New K2000 sherib Troubleshooting and Beginner Help 13 06-08-2009 08:34 AM
K2000 Deal rickn Photographic Technique 4 06-02-2009 09:30 AM



All times are GMT -7. The time now is 07:38 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top