Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-16-2009, 02:00 PM   #1
New Member




Join Date: Dec 2009
Posts: 8
A Newbs sad story with a K-x

Greetings.

I am new to this community, and to DSLR's. I've decided to go for the K-x, as it's reputation already, as a very affordable entry level DSLR, is infamous

Today I recieved my lovely new K-x. It's spanking. However, I cannot get it to work!

SD card - check, batteries - check, lenses check, power on - check.

Hmm....can't take any pictures. No shutter action at all. No auto focus. Nothing. Every time I lightly press the shutter release, the details on the screen flash. But nothing happens.

Tried the other lense, same.

Took the lenses off, the shutter works....

Am I bring a complete newb. Am I missing something? Please help this very frustrated chap, who really needs his camera!

Thankyou

12-16-2009, 03:36 PM   #2
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 4,862
QuoteOriginally posted by MelAllsop Quote
Took the lenses off, the shutter works...
If that's true, I think it means you are not installing the lenses correctly. Try reading the instructions about this in the manual. It's a little weird. The camera will work with no lens, however, not work with a partly installed lens*.

*doesn't apply to advanced users who change the Using aperture ring setting to Permitted.
12-16-2009, 03:53 PM   #3
New Member




Join Date: Dec 2009
Posts: 8
Original Poster
Hi Just1MoreDave

I thought that too. But, the instructions are very clear. Aligned the red dots, turn clockwise until you hear an audible "click". The camera does this fine. But when I attached the lense, I get nothing.....

I know this wierd. I'm a pretty competant chap. But this has thrown me. I literally can't do anything different.
12-16-2009, 03:56 PM   #4
Pentaxian




Join Date: Feb 2009
Location: Alameda, CA
Posts: 3,198
What are the lenses that you try?

I'm not sure if the lenses matter, but have to ask.

12-16-2009, 04:01 PM   #5
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,888
Did you see the focus confirmation on the viewfinder? Also, when the screen flashes that usually means the camera can not achieve proper exposure.

What mode is the camera on?
12-16-2009, 04:02 PM   #6
New Member




Join Date: Dec 2009
Posts: 8
Original Poster
The lenses I got with the "kit" are:

SMC Pentax DAL 18-15 &
SMC Pentax DAL 50-200

I've just tried again to see if there is any other way these lenses can go on. I cannot attache then any differently.

When the lenses are attached, something is stopping them from working. IE no focus or shutter action. Completely baffled!
12-16-2009, 04:08 PM   #7
New Member




Join Date: Dec 2009
Posts: 8
Original Poster
There is no focus confirmation on the viewfinder.

I get the picture mode icon IE Auto Pict
Shake Reduction
Shutter speed and Aperture
ISO

Depressing the shutter release, does nothing. No focus, shutter action at all.

Thankyou very much for taking the time to reply to my troubles.
12-16-2009, 04:09 PM   #8
New Member




Join Date: Dec 2009
Posts: 8
Original Poster
Sorry, the camera is on Auto Pict mode.

12-16-2009, 04:23 PM   #9
Veteran Member
causey's Avatar

Join Date: Feb 2009
Location: Arlington, VA
Photos: Albums
Posts: 3,758
what kind of batteries are you using? the ones included in the original package?
12-16-2009, 04:29 PM   #10
Veteran Member




Join Date: Sep 2007
Location: La Crescenta, CA
Posts: 7,452
Probably a dumb question, but is the AF/MF switch turned to AF? Lens cap off?
12-16-2009, 04:29 PM   #11
Veteran Member
fccwpe's Avatar

Join Date: Mar 2009
Location: Perris, CA
Photos: Gallery
Posts: 380
maybe you're not turning the lens far enough? Is the red alignment dot on the lens directly under the center of the PENTAX logo on the camera?
12-16-2009, 04:31 PM   #12
Veteran Member




Join Date: Sep 2007
Location: La Crescenta, CA
Posts: 7,452
QuoteOriginally posted by fccwpe Quote
maybe you're not turning the lens far enough? Is the red alignment dot on the lens directly under the center of the PENTAX logo on the camera?
He said he heard the click when it locked into place... this shouldn't be it...
12-16-2009, 04:34 PM   #13
Igilligan
Guest




I am with DWB...

Are you sure the camera is not in Manual focus mode? it will not snap a pic in MF unless you have manually focused the lens to focus confirmation.
12-16-2009, 04:45 PM   #14
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,925
QuoteOriginally posted by Igilligan Quote
Are you sure the camera is not in Manual focus mode? it will not snap a pic in MF unless you have manually focused the lens to focus confirmation.
That doesn't sound right. What if you are taking an abstract image of some bokeh? How would you go about taking that picture if you want nothing in focus?
12-16-2009, 04:47 PM   #15
Veteran Member
Eruditass's Avatar

Join Date: Jul 2009
Location: Pittsburgh, PA
Photos: Gallery | Albums
Posts: 2,206
Yeah, that doesn't sound right, unless trap-AF is enabled - but it is off by default - and actually can't be used with AF lenses w/o a AF/MF switch on the lens (although I wish it could).

This is baffling - if you have a P&S take a video!

Maybe try putting it on MF and seeing if it will snap a picture.

What happens when you go in Video or LiveView mode? If you half-press - do you hear the motor trying to focus?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, check, k-x, lenses, pentax help, photography, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Travel Sad story: both of my kids incarcerated at Fort Henry, Ontario newmikey Post Your Photos! 5 08-23-2010 05:40 PM
50-135/2.8 SDM lens sad story, happy end !! Itzik Pentax SLR Lens Discussion 10 11-13-2009 12:36 PM
Nature pointless struggle - sad story axl Post Your Photos! 20 11-02-2009 10:36 AM
Another sad, but true, Wolf Camera Story Ed in GA General Talk 19 06-17-2008 05:33 PM
The sad story of the budding bird photographer mingdie Post Your Photos! 7 01-11-2008 01:07 PM



All times are GMT -7. The time now is 06:57 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top