Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-30-2010, 01:20 PM   #1
New Member
arratetxu's Avatar

Join Date: Aug 2009
Location: Den Haag, Netherlands
Posts: 7
Problem with K10 - Green pictures

Hello everybody,

I normally just read your posts but today I had a problem with my camera I'm scared about, so I decided to post myself . Yesterday I was looking after a friend's child and he hit my camera in the backside while playing. Today I've been trying to make some pics and I've discovered that the images were green... I can see the image and shapes with no problems, but the whole picture is green (like with a green filter) and sometimes with some colourful vertical stripes crossing it. The menu can be seen with no problem, so it's not the screen itself. As I can see the object I am capturing, I assume the lense is also ok, so the problem could be in the camera's body itself? I'm on holidays, so I cannot try other lenses or go to a dealer. I haven't changed any balance and I am trying different methods with no luck at all. Any ideas?

Thanks a lot!!

04-30-2010, 01:43 PM   #2
Veteran Member
Tuner571's Avatar

Join Date: Mar 2008
Location: Ohio
Photos: Gallery | Albums
Posts: 1,550
To me it sounds like you may have knocked off a connection to the camera's sensor or something in that respect. At first I was thinking that maybe you bumped something on the white balance, but when you said that you were seeing some colorful vertical stripes on your photos as well; the only thing left to blame is the sensor. Unfortunately, you are probably going to have to send it in to be repaired and since the sensor seems to be damaged the price to repair it will most likely be quite high.
04-30-2010, 07:06 PM   #3
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,913
I'd try another card. Maybe you can just borrow one from someone to shoot off a few and check.
05-01-2010, 05:04 AM   #4
Veteran Member




Join Date: Aug 2007
Photos: Gallery
Posts: 1,563
Many things can have been broken.

I wonder, if you play back images that were taken before the blow, do they look Ok?
If not, if they are green as well, the problem may be in the image reproduction or the SD card access circuits / connections and there may be a small chance that new pictures are taken ok but shown in green on the display.

If the problem is consistent with other SD cards, I guess you are in for a repair.
Bad luck that this is happening during your vacation....

- Bert

05-01-2010, 06:49 AM   #5
Zav
Pentaxian
Zav's Avatar

Join Date: Feb 2009
Photos: Gallery
Posts: 1,339
Green pictures with K10 is a known problem, but I haven't heard about it for a long time. I remember two or three years on a french forum, a few users had this problem. Their K10 have been serviced and fixed.
05-01-2010, 08:35 AM   #6
New Member
arratetxu's Avatar

Join Date: Aug 2009
Location: Den Haag, Netherlands
Posts: 7
Original Poster
QuoteQuote:
At first I was thinking that maybe you bumped something on the white balance, but when you said that you were seeing some colorful vertical stripes on your photos as well; the only thing left to blame is the sensor.
Ah yes, the white balance was the 1st thing that crossed my mind until I saw the other colours too. Now it is even worse. The pic is not even complete, so you might be right...

QuoteQuote:
I'd try another card. Maybe you can just borrow one from someone to shoot off a few and check.
I've done it and the problem remains .

QuoteQuote:
I wonder, if you play back images that were taken before the blow, do they look Ok?
If not, if they are green as well, the problem may be in the image reproduction or the SD card access circuits / connections and there may be a small chance that new pictures are taken ok but shown in green on the display.
Yes, the pictures I took before look ok. Only the pictures taken after the blow are damaged.

QuoteQuote:
Green pictures with K10 is a known problem, but I haven't heard about it for a long time. I remember two or three years on a french forum, a few users had this problem. Their K10 have been serviced and fixed.
I think it will be my only choice as well... I hope it won't be very expensive .

I am attaching a picture I've just made... Looks much worse than yesterday

05-01-2010, 10:15 AM   #7
Zav
Pentaxian
Zav's Avatar

Join Date: Feb 2009
Photos: Gallery
Posts: 1,339
This is obviously a sensor problem.
I saw a used K10 for sale for 150€ yesterday. If the fixing is too expensive, well, buy another camera.
05-01-2010, 01:46 PM   #8
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
QuoteOriginally posted by arratetxu Quote
Ah yes, the white balance was the 1st thing that crossed my mind until I saw the other colours too. Now it is even worse. The pic is not even complete, so you might be right...



I've done it and the problem remains .



Yes, the pictures I took before look ok. Only the pictures taken after the blow are damaged.



I think it will be my only choice as well... I hope it won't be very expensive .

I am attaching a picture I've just made... Looks much worse than yesterday

I'm betting that the repair is going to be far more expensive than a replacement. Unless you have some sort of extended warranty that is or if by chance it's still under original warranty. ZAV says this is an old problem from a few years ago, can't say I remember ever seeing anything like it. I'm not saying He didn't.

One thing you Might try if you haven't already, Reload the firmware. Maybe something has gone corrupt in the software. Can't hurt to try before you start spending money to fix it.

Good luck..



05-01-2010, 09:38 PM   #9
Zav
Pentaxian
Zav's Avatar

Join Date: Feb 2009
Photos: Gallery
Posts: 1,339
I made a little research and found people complaining about green pictures from 2007.
This is the kind of pictures which were taken:

The users who had this problem sent back their K10 to Pentax for fixing.
Your problem seems worse :/
05-02-2010, 10:37 AM   #10
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
I'm not saying it is, but this looks more like a WB problem. At the very least, it can be somewhat corrected to get a Usable image. Not so with the OPs camera.

05-05-2010, 03:18 AM   #11
New Member
arratetxu's Avatar

Join Date: Aug 2009
Location: Den Haag, Netherlands
Posts: 7
Original Poster
Thanks again for your valuable answers . Firts, my pictures were just green, exactly like the one that Zav posted and after taking a few, the problem became worse . I am going to try realoading the software before sending it for reparation or look for a replacement, although I found out that the parents of this children have an insurance, so the amount could be covered (I hope...)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, pentax help, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K10 D Fault. Images are Green. Please Help. 1cut808 Pentax DSLR Discussion 4 12-21-2009 05:46 PM
K10D intermittent green pictures and vertical color banding...whats up? PaddyB Pentax DSLR Discussion 1 08-02-2009 02:46 AM
K200D green pictures ronm1562 Pentax DSLR Discussion 5 03-01-2009 11:52 AM
K10+Green Monster Seats+Sigma70-200+1.4tc :) vievetrick Post Your Photos! 4 08-03-2007 09:09 PM
Pentax K10 - dark pictures Maros Pentax DSLR Discussion 22 07-29-2007 11:52 AM



All times are GMT -7. The time now is 08:21 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top