Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-08-2010, 01:39 PM   #1
Junior Member




Join Date: Apr 2010
Posts: 28
my mac not detecting my pentax k-x???

i plug it in .. turn the camera on nothing happens ....


i tried changing it to picture transfer in the usb option and that didnt help so i wen tback to the default mass storage .. still doesnt work

05-08-2010, 02:28 PM   #2
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,478
A little bit more info? Which Mac? What OS? Have you tried more than 1 USB port? Are you plugging it into the keyboard or the Mac or are you plugging it into a USB hub?
05-08-2010, 02:46 PM   #3
Junior Member




Join Date: Apr 2010
Posts: 28
Original Poster
mac os x 10.6.3
2ghz intel core 2 duo
4gb ram

plugged in all usb spots

Last edited by jupzchris; 05-08-2010 at 02:57 PM.
05-08-2010, 03:18 PM   #4
Site Supporter
boriscleto's Avatar

Join Date: Dec 2009
Location: Liverpool, NY
Photos: Gallery
Posts: 12,478
Could be a bad USB cable or USB port on the camera. Can you try it on another computer?

05-08-2010, 03:35 PM   #5
Site Supporter
Fries's Avatar

Join Date: Oct 2009
Location: Gauw
Photos: Gallery | Albums
Posts: 1,864
It could be a memory card issue. When you plug in your KX it should function as (rather expensive) card reader. If there is a problem with the card this could explain why it isn't showing on your screen. You could try another card perhaps or buy a cheap card reader. If you have access to another computer you could see if the problem persist.

I know the KX is supported now trough this update: Digital Camera Raw Compatibility Update 3.1

Have you tried turning your camera on before you plug it in. Perhaps that will kick start the process. I just tried this out on my Mac without any problems.

Well, thats all I can think of! Good luck.
05-08-2010, 03:39 PM   #6
Senior Member
Perrumpo's Avatar

Join Date: Mar 2010
Location: Maryland
Photos: Gallery | Albums
Posts: 207
QuoteOriginally posted by Fries Quote
It could be a memory card issue. When you plug in your KX it should function as (rather expensive) card reader. If there is a problem with the card this could explain why it isn't showing on your screen. You could try another card perhaps or buy a cheap card reader. If you have access to another computer you could see if the problem persist.

I know the KX is supported now trough this update: Digital Camera Raw Compatibility Update 3.1

Have you tried turning your camera on before you plug it in. Perhaps that will kick start the process. I just tried this out on my Mac without any problems.

Well, thats all I can think of! Good luck.
Even before the RAW compatibility updates, the card would still mount.

OP, is the card showing up in the Finder's sidebar or just not in iPhoto or whatever app you are using? Can you mount it via Disk Utility?

If you can see it in Disk Utility, you can run diagnostics.
05-08-2010, 03:59 PM   #7
Junior Member




Join Date: Apr 2010
Posts: 28
Original Poster
think im going to go with bad cord

sucks cuz i just opened it straight out the box from QVC

the card reads fine in my card reader
05-09-2010, 11:08 AM   #8
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Try it on another PC (at home, school, work or where ever)

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Utility 3 crashes in Mac OS X.6 jmschrei Digital Processing, Software, and Printing 2 04-03-2010 05:07 PM
Pentax *istD not detecting aperture setting and not taking photos. wolf Pentax DSLR Discussion 2 06-08-2008 07:12 PM
Pentax or Mac ? elne Photographic Technique 12 03-08-2008 05:18 AM
K10D photo series - mac / aperture / .mac Tom M Photographic Technique 7 12-29-2007 03:13 PM



All times are GMT -7. The time now is 11:48 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top