Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-09-2010, 08:40 PM   #1
Inactive Account




Join Date: Dec 2009
Posts: 14
Problem with K7

Recently received K7 back from Pentax repair to correct a focus problem. Now, focus is very sharp. New problem: When camera powers up in AFS mode with 16-50 DX* lens (only one I have presently) also set to auto, camera will not shoot 90% of the time. Instead, focus symbol in viewfinder will constantly flash like it is hunting. When focus setting is on "C" or manual, camera will shoot right away when powered up. Conditions don't seem to matter, it does whenever/wherever. I think software is up to date.

So, does the camera need to go AZ again for repair or am I missing something here?

Thanks for the help....

05-09-2010, 08:55 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,357
AFS by default disallows shooting while not in focus; the other two modes do not. This is why you're experiencing this kind of behavior.

Possible causes as far as I can see:
  • Is the switch on the lens set to MF?
  • Is the lens broken?
  • Try going to MF mode on the lens (not the camera) and focusing. Does the camera show that the image is in-focus and do a double beep? If so, then the lens is likely to blame, or your SDM system is broken somewhere along the line.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-09-2010, 08:57 PM   #3
Site Supporter




Join Date: Aug 2007
Location: Dayton, OH
Posts: 365
You say the camera fires right away when in AF.C mode? If it's firing immediately, without trying to focus, that sounds like the behavior you'd expect with a manual focus lens. And you can have the camera treat the DA* 16-50 as a manual focus lens when the switch on the lens body is set to "MF".

So, what is the switch in front of your zoom ring set to?
05-09-2010, 09:11 PM   #4
Inactive Account




Join Date: Dec 2009
Posts: 14
Original Poster
1. Yes, the switch on lens is set to "AF," while camera is set to AFS.....then camera won't shoot when I turn it on. It seems to focus, but focussing symbol in viewfinder blinks and camera won't shoot. This goes on and on, so something is amiss.

2. With the initial focussing problem (every shot was blurry), I sent the lens in with camera and Pentax indicated lens is working fine.

3. When I try shooting in "C" mode, camera takes just a moment to focus, then shoots.

4. When I try in manual mode, I switch camera to manual and also lens to MF. I turn camera on, focus, and then shoot....no problems.

What do you think?

05-09-2010, 09:28 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,357
In AFS, your camera won't shoot until the image is in focus, so that's normal. Now we need to find out why it won't focus! There could be something wrong with the camera, or with the lens, but at this point it sounds like more of a camera issue.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, focus, k7, photography, repair
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Card read problem K20d. Have you had this problem? rsi1986 Pentax DSLR Discussion 8 12-27-2008 05:25 AM
Problem? straightshooter Pentax DSLR Discussion 3 10-19-2008 10:01 PM
What was the problem here? straightshooter Pentax Film SLR Discussion 15 09-15-2008 02:46 PM
Had a Problem benjikan Pentax DSLR Discussion 74 02-28-2007 10:29 AM
Have I got a problem here? anthonysemone Pentax DSLR Discussion 3 01-17-2007 07:18 AM



All times are GMT -7. The time now is 08:41 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top