Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-05-2007, 12:07 AM   #1
Inactive Account




Join Date: Jan 2007
Location: Sydney, Australia
Posts: 25
Issue with Pentax K100D

Recently I have had problems when attaching the 18-55mm Sigma lens to the camera body.

The camera shows MF and no aperture setting. I twist the lens a couple of times then it works fine. One thing I have noticed on the camera is the 5 spring loaded contacts seem ok however the 3rd seems to be flatter than the others. Is this correct or do I have a problem?

08-05-2007, 05:03 AM   #2
Veteran Member




Join Date: Sep 2006
Location: Virginia Beach VA USA
Photos: Gallery
Posts: 1,364
Try cleaning the contacts of both the lens and the camera, and see if that helps.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, issue with pentax, lens, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vivitar MC Tele Converter 2X PK-A/R-PK issue...or no issue? WiseOx Pentax SLR Lens Discussion 5 06-11-2014 01:14 PM
K100D shooting ISO 1600 issue: Images have orange horizontal streak kveldalf Pentax DSLR Discussion 8 11-02-2008 05:39 AM
A printer issue, or a processing issue... FHPhotographer Digital Processing, Software, and Printing 0 10-03-2008 12:13 PM
K100D Super issue? hdvalente Pentax DSLR Discussion 12 11-29-2007 09:13 AM
K100D battery issue Pierrot Pentax DSLR Discussion 22 04-04-2007 10:04 AM



All times are GMT -7. The time now is 04:44 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top