Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-02-2010, 05:53 AM   #1
New Member




Join Date: Jun 2010
Location: Upstate NY
Posts: 16
Broken Av/EV button?

Hi from a brand new forumite.

I've got a K100D Super with a problem. Last night I noticed that the Av/EV button appeared not to work. The problems I am experiencing are:

In M mode, I can turn the e-dial to change shutter speed but when I press the Av/EV button to change aperture, the aperture stays the same but the shutter speed still changes.

In P mode and I press the Av/EV button, there is no EV compensation on the screen.

In AV mode, the e-dial changes both shutter speed and aperture regardless of if the Av/EV button is pressed or not

In Tv mode, pressing the Av/EV button and turning the e-dial does nothing.

Of course my problem could be operator error, but I've changed the batteries, been all over the manual and reset the camera to factory settings, but none of that seems to have worked. Has anyone ever had a busted Av/EV button and what did it cost to get it fixed?

Thanks in advance.

06-02-2010, 08:56 AM   #2
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Sounds like you've diagnosed the problem correctly. You might try some compressed air or some other method of cleaning around/around the button.
06-02-2010, 10:40 AM   #3
New Member




Join Date: Jun 2010
Location: Upstate NY
Posts: 16
Original Poster
Thanks. I will try that.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, button, camera, change, changes, dslr, e-dial, mode, photography, press, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken dreams, broken camera brkl Post Your Photos! 3 03-10-2009 05:08 PM
Broken AV Button highyellow1 Pentax DSLR Discussion 4 07-16-2008 07:00 AM
anyone else had a problem with broken shutter button on the D-BG2 battery grip? sholtzma Pentax Camera and Field Accessories 4 07-06-2008 01:27 PM
Do you use the AF button? PentaxPoke Pentax DSLR Discussion 36 01-28-2008 08:32 PM



All times are GMT -7. The time now is 05:46 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top