Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-07-2010, 12:59 AM   #1
Junior Member




Join Date: May 2010
Photos: Gallery
Posts: 43
Blue images in k2000

Hi all,

I recently purchased a k2000 from a member of this forum. The camera seems great and I have a Quantarray DA 28-90mm on it, and 2 manual lenses (not all at once mind you )

So, a few weeks ago, while messing with the aperture ring on the DA lens, it started taking all Blue photos, till I switched back to 'A'.

Recently, I bought a f/1.7 50mm prime lens (manual). Taking pics with it I got a blue image as well.

Then this weekend, I was shooting with the DA lens and one of the images was blue. I can't figure out why...

I'm attaching 2 examples.

Attached Images
View Picture EXIF
PENTAX K2000  Photo 
View Picture EXIF
PENTAX K2000  Photo 

Last edited by koguma; 06-07-2010 at 01:04 AM.
06-07-2010, 02:45 AM   #2
Site Supporter
kiwi_jono's Avatar

Join Date: Dec 2009
Location: Christchurch, New Zealand
Photos: Gallery | Albums
Posts: 1,085
Are you sure that the White Balance (WB) is not set to indoor incandescent?

I have made the mistake of leaving my K-x on this and forgetting several times with very similar results!
06-07-2010, 03:40 AM   #3
Veteran Member
StarDust's Avatar

Join Date: Apr 2008
Location: Uppsala, Sweden
Posts: 400
This is clearly a white balance problem, it is compensating for too much yellow such as (primarily) indorrs or evenings where the scenary is dark.
Your white balance is calibrated wrong, check the settings in your camera.
06-07-2010, 04:12 AM   #4
Site Supporter




Join Date: Mar 2009
Location: Gladys, Virginia
Photos: Gallery
Posts: 16,250
Definitely looks like some how you got your white balance changed to tungsten. Should be able to fix it in postprocessing.

06-07-2010, 07:46 AM   #5
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
According to the EXIF, it appearsth WB is set to "manual" - you must have been experimenting with setting WB manually. As others have said, set it back to auto. Or if you are going to mess with it, you need to set it properly for the type of light. The aperture ring is a red herring here.
06-07-2010, 04:45 PM   #6
Junior Member




Join Date: May 2010
Photos: Gallery
Posts: 43
Original Poster
I believe WB was set to auto..

QuoteOriginally posted by Marc Sabatella Quote
According to the EXIF, it appearsth WB is set to "manual" - you must have been experimenting with setting WB manually. As others have said, set it back to auto. Or if you are going to mess with it, you need to set it properly for the type of light. The aperture ring is a red herring here.
That's very weird, I'm almost positive I had the WB set to auto. Perhaps that is why it did that for only one picture? If I had the WB set wrong manually every picture would have been blue, no?

I'll take a look at the camera again when I get home tonight.

Thanks everyone! If it is an issue with WB being set to auto, should I be setting it manually?
06-07-2010, 05:09 PM   #7
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Not in general, no. The only time auto WB generally has problems is when dealing with very strongly colored light - like tungsten lighting. Then it generally won't try hard enough to remove the storng color cast. But no need for manual unless you really really want to - just using the tungsten preset should be fine.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, da, dslr, images, k2000, lens, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K2000 Duane Pentax DSLR Discussion 6 12-20-2009 05:28 PM
Night Blue sky, blue see Rense Post Your Photos! 11 10-10-2009 01:01 AM
A variety of images with FA* 200/4 Macro (no bugs) - VLF competition images Marc Langille Post Your Photos! 28 08-22-2008 07:28 PM
High ISO concert images with Tam 28-300 (Images) jsundin Post Your Photos! 2 07-05-2007 08:19 AM
A few K10D tourist images of Italy (9 images, about 200kb each) volosong Post Your Photos! 2 04-24-2007 04:29 AM



All times are GMT -7. The time now is 09:50 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top