Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-18-2010, 05:32 AM   #1
Site Supporter




Join Date: Jun 2010
Location: Massachusetts
Photos: Gallery
Posts: 16
K200D screen shuts off

I have had a K200D since last year. I really like it, but one thing has always annoyed my. The screen on the back shuts off. For instance, what inspired me to join you all is that I just tried to format my memory card. I pushed the menu button and tried to arrow over, but the screen shut off. So, I pushed the menu card, tried to arrow over again, and the screen went off again. It took 7 tries to get the screen to stay on. Unfortunately, this is not at all unusual. I had the lens cap still on, set in Tv or Sv mode. Am I doing something wrong or is it my camera? It happens a lot when I try to review images, too, or when I do just about anything that requires reviewing the screen. Thanks.

06-18-2010, 05:46 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,259
Are you accidentally pressing the shutter button (even if only half way) while holding the camera? If so, then the behavior is normal.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

06-18-2010, 06:39 AM   #3
Senior Member




Join Date: Jul 2008
Location: Milwaukee
Posts: 129
Yeah, this happens to me if I even touch the shutter button. The lightest touch turns off the screen for me.
06-18-2010, 06:40 AM   #4
Site Supporter
cdurfor's Avatar

Join Date: Apr 2009
Location: Washington, DC
Photos: Gallery
Posts: 534
I too have noticed this problem with my K200D during re-format attempts. Its not related to depressing the shutter button and it is an occasional event. Answer would be great...

06-19-2010, 06:12 AM   #5
Junior Member




Join Date: Jul 2008
Location: Pa.
Posts: 27
Tried to do it on mine and does not go off. Check Batteries ? I use Eneloops.
06-19-2010, 04:01 PM   #6
Veteran Member
kkoether's Avatar

Join Date: Jul 2008
Location: Huber Heights, OH, USA
Photos: Gallery | Albums
Posts: 576
If you have the battery grip it is real easy to bump the shutter button on the grip and cause this. Been there done that.

Last edited by kkoether; 06-20-2010 at 08:32 AM. Reason: spelling
06-19-2010, 09:46 PM   #7
Pentaxian
LFLee's Avatar

Join Date: Aug 2009
Location: Western MA
Photos: Gallery | Albums
Posts: 2,264
agree with kkoether, probably the shutter on the battery grip is put to 'on' .... if u have a battery grip...
06-19-2010, 10:50 PM   #8
Veteran Member
KarenH's Avatar

Join Date: Jun 2010
Location: Berkel en Rodenrijs
Photos: Gallery | Albums
Posts: 828
Sounding like a broken record, but with the battery grip on it happens very easy.
Took me a while before I understood what was going on.

06-21-2010, 04:36 AM   #9
Site Supporter




Join Date: Jun 2010
Location: Massachusetts
Photos: Gallery
Posts: 16
Original Poster
Thanks

I do have a battery grip, which has lost some functionality. It suddenly stopped taking pictures. It'll autofocus, but then not take the shot. I took the camera out yesterday and the problem did not happen at all. Maybe it was just that. Thanks for all your feedback.
06-22-2010, 09:40 AM   #10
Forum Member




Join Date: Oct 2009
Location: North Oregon Coast
Posts: 89
I had a similar problem with a K100d. Eventually discovered that it only happened when using a particular Sigma lens. Strange, but true.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
arrow, camera, card, dslr, k200d, menu, photography, screen
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20 shuts down, help Lorraine S Pentax DSLR Discussion 6 05-21-2010 04:26 PM
Display Data doesn't shuts down bethtphotos Pentax DSLR Discussion 2 10-24-2009 02:17 PM
Seeking advice on focusing screen (split screen) for K200D Ari Freund Pentax DSLR Discussion 8 07-31-2009 03:00 AM
NY AG Shuts Down Scammy Camera Stores indytax General Talk 3 07-03-2009 01:37 AM
K200D focus Screen..... Daveinozbikes Pentax DSLR Discussion 2 05-21-2009 10:26 PM



All times are GMT -7. The time now is 03:35 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top