Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-20-2010, 09:52 AM   #1
Forum Member




Join Date: Jan 2009
Location: Salisnury, Canada
Posts: 68
Dark purple pictures from K-X

A strange thing happened to me today, went for walk and shot few pictures, all of them completely dark with a purple tint, no error messages, batteries charged.
Came home, tried the LiveView and sure enough, dark purple display. After several seconds the display started flickering all kinds of colors after that it settled to normal.
Shot few pics, all OK. Turned the camera off for a bit, turned it on again in LV and purple display again. Five seconds later display changed to normal again. It seems doing the same thing when the camera is off for few minutes.
Any ideas except to sending it for repair?

07-20-2010, 03:36 PM   #2
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,556
My guess would be energy problems. As heart a lot, try Sanyo Eneloops and maybe all problems are gone.

My K-7 also turns black on the backscreen on liveview when the accu dried up, but just can ceep the camera up running.
07-20-2010, 03:49 PM   #3
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,596
Temperature related? In the same way that the screen can start to play up when it gets very cold, it can also start to play up when it gets very warm.

From some of those photos you took at the time the display went weird, what was the camera temperature (it's recorded in the EXIF, and readable via PhotoMe and exiftool).

I guess the main thing to ask is if the photos themselves were OK.
07-20-2010, 07:26 PM   #4
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by luma Quote
A strange thing happened to me today, went for walk and shot few pictures, all of them completely dark with a purple tint, no error messages, batteries charged.
Came home, tried the LiveView and sure enough, dark purple display. After several seconds the display started flickering all kinds of colors after that it settled to normal.
Shot few pics, all OK. Turned the camera off for a bit, turned it on again in LV and purple display again. Five seconds later display changed to normal again. It seems doing the same thing when the camera is off for few minutes.
Any ideas except to sending it for repair?

Do your Photos have a purple cast or are you just seeing it on the rear screen? Either way, short of trying some New batteries, you might want to send it for warranty service before it expires.



07-21-2010, 08:25 PM   #5
Forum Member




Join Date: Jan 2009
Location: Salisnury, Canada
Posts: 68
Original Poster
The batteries and temperature are definitely not an issue here. It is not just purple display, but the actual shots are very dark and purple as well. When I switch to LV, I see on the display exactly what the sensor is seeing and what comes out in the picture.
I think that sensor failed and my only option is warranty repair.
07-21-2010, 08:31 PM   #6
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,596
Post the pictures pls.

Sorry to sound heartless, but it would be interesting to see what a dying sensor looks like.
07-22-2010, 02:24 AM   #7
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,696
Well look at this way, if you ever get purple fringing from your lenses, your pictures will not suffer.
09-20-2010, 03:07 PM   #8
Forum Member




Join Date: Jan 2009
Location: Salisnury, Canada
Posts: 68
Original Poster
I have my camera back from warranty repair by Pentax Canada (and yes, I had to pay $50 handling fee because the camera was purchased in States). The repair bill says that they had to replace the circuit board, apparently they did not change the sensor itself. Camera works fine now.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, display, dslr, photography, pictures, shot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-X Purple color in the middle of the pictures! Help cih Troubleshooting and Beginner Help 7 12-15-2010 12:37 AM
Dark pictures sometimes on K20D. jbrowning Pentax DSLR Discussion 18 08-04-2010 08:09 AM
Pictures too dark Sargmaster Pentax Camera and Field Accessories 9 12-15-2009 03:53 AM
K10D Lens Help / Dark pictures Amydaveg Pentax DSLR Discussion 2 04-05-2009 08:04 PM
Purple pictures Sebbe_J Pentax DSLR Discussion 7 12-30-2007 04:29 AM



All times are GMT -7. The time now is 04:12 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top