Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-12-2010, 05:35 AM   #1
Forum Member




Join Date: Aug 2008
Photos: Gallery
Posts: 66
My autofocus is broken? Please Help!

HI

Today wanted to make some photos with my Pentax K20 and DA macro 35mm limited.

I don't know why the autofocus stopped working. If I swich the button on AF.C or AF.S the MF still show on my display when I look thru lens. Does it means my autofocus was froken? The camera is like new bought one year ago.

The same problem with the kit lens 18-55mm II. It does not matter where I let the button or AF or MF..it's like the camera does not respond. It still show MF on display and don't want to autofocus.

Does it means the autofocus is broken or..is something from menu?

What should I do. Does anyone faces this problem too?

Thanks for your help,
Marius

08-12-2010, 05:44 AM   #2
Site Supporter




Join Date: Sep 2006
Location: WV
Posts: 1,495
Remove the lens, and check the screw drive on the body mount. Is it retracted or extended? It should be retracted if the switch is set to mf, otherwise it should be extended. If it's retracted when it should be extended, maybe it is stuck, try jiggling it to free it.

Other than that, I'm drawing a blank.
08-12-2010, 06:01 AM   #3
Forum Member




Join Date: Aug 2008
Photos: Gallery
Posts: 66
Original Poster
thanks for your reply MPrince.

Yes, the screw body works fine. It's extended when AF and retracted when MF. The problem is that the camera still show me MF on the display when looking thru lens.

Anyone any other idea what should be the reason.

Thanks
08-12-2010, 06:18 AM   #4
Veteran Member




Join Date: Dec 2009
Location: Bucharest
Posts: 482
if the contacts are clean then I'm sorry for you because probably your camera has a major defect. Any other signs, does the focus confirmation appears when you do MF, can you take pictures?
I know it sucks, my sensor went bad a few weeks ago and it was not a nice feeling.

Try resetting it, change the batteries. Good luck!

08-13-2010, 03:12 AM   #5
Forum Member




Join Date: Aug 2008
Photos: Gallery
Posts: 66
Original Poster
yes the focus confirmation appear, everything works well, I can take photos on MF. Just can't take photos using AF. Even if a put the camera on AF, the MF indicatior still appears on my display. Have no idea why.

Maybe because the batter is low? I'll try to charge it.

Last edited by marius; 08-13-2010 at 03:22 AM.
08-13-2010, 05:30 AM   #6
Veteran Member




Join Date: Dec 2009
Location: Bucharest
Posts: 482
try a factory reset from the menu and refresh the battery.

The simplest explanation could be that the AF switch on the body is faulty - try to jiggle it a little, make a few dozens complete switches, maybe use a contact spray on the button and make 5 minutes of swithing in all positions with the battery removed (although the body being weather sealed, the cleaning liquid might not reach the contact) then wait a couple of hours hour for the contact spray to dry and try again with the battery in and power on.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, button, camera, display, dslr, lens, mf, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K7 Autofocus selection broken ? holdgaj Pentax DSLR Discussion 0 08-24-2009 07:19 AM
Broken Autofocus? Kiz Troubleshooting and Beginner Help 3 03-16-2009 12:48 PM
Broken dreams, broken camera brkl Post Your Photos! 3 03-10-2009 05:08 PM
For Sale - Sold: FS: Autofocus film cameras and autofocus lenses Not Registered Sold Items 15 03-17-2008 07:08 AM



All times are GMT -7. The time now is 12:50 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top