Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-16-2010, 02:16 AM   #1
New Member




Join Date: Jun 2010
Location: St.Petersburg
Posts: 5
K20D stabilizer bug

Hello, fellows!
I own Pentax K20D.
The stabilizer in my camera started working in a random order, for example, in the afternoon, when exposure is very short, blurry images are obtained. I removed the lens from the camera, turned off the stabilizer, looked at a large exposure to the matrix - it shakes with a very large amplitude! The same thing I saw in the Live View mode - the display randomly shaking. It's impossible to switch off stabilizer?
What could happen with the stabilizer and is there a way to solve the problem without a service center?

08-16-2010, 03:28 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,228
There's a switch below the arrow keys that disables shake reduction. What you're describing sounds like normal operation, though.

You should ask further questions here: Pentax Beginner's Corner Q&A - PentaxForums.com

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-16-2010, 03:46 AM   #3
New Member




Join Date: Jun 2010
Location: St.Petersburg
Posts: 5
Original Poster
No.
1. I got motion blur on short exposures (less then 1/60 of second) both with stab enabled and disabled
2. I had this camera for 2 years and I know where and how to disable stab, but that switch has no effect to the behavour of the Share reduction system: that fires randomly!
3. And the matrix shakes very hard - I can fell this by hands when shoting
4. Or possible this is not shake reduction, is it Dust Removal system? O_o

Last edited by OmegaMale; 08-16-2010 at 03:51 AM.
08-16-2010, 03:52 AM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,228
Are you talking about a stabilizer on your lens as well? In live view mode, it's normal for the SR system to work continuously.

Keep in mind that one common mistake frequently made is that users forget to let the SR system arm. If you take a photo, and SR is on, but SR icon wasn't lit at the time you took the photo, the system might backfire.

Your hypothesis in point #4 is very interesting, but again, you should be able to tell by the sound of the system. Should there be something wrong with the camera, it'll obviously need to be sent in.


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-16-2010, 08:18 AM   #5
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,912
You can not feel SR. You can feel dust removal shaking.
08-16-2010, 12:28 PM   #6
Inactive Account




Join Date: Apr 2010
Posts: 12
See my post under IS broken:

https://www.pentaxforums.com/forums/pentax-dslr-discussion/99210-broken.html
08-17-2010, 12:43 AM   #7
New Member




Join Date: Jun 2010
Location: St.Petersburg
Posts: 5
Original Poster
QuoteOriginally posted by SpecialK Quote
You can not feel SR. You can feel dust removal shaking.
I can feel SR from the start of using my camera (little shakes and low sound, just try It )

DR shaking camera much more hard. But who know what is my current problem
08-17-2010, 12:43 AM   #8
New Member




Join Date: Jun 2010
Location: St.Petersburg
Posts: 5
Original Poster
QuoteOriginally posted by Senseicameratech Quote
Ok, thank you.

08-17-2010, 08:03 AM   #9
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
QuoteOriginally posted by OmegaMale Quote
I can feel SR from the start of using my camera (little shakes and low sound, just try It )

DR shaking camera much more hard. But who know what is my current problem
The sound you hear on startup *is* the dust removal - just a shorter version of it than what you get if you choose it from the menu later. You can turn off the dust removal on startup via another menu item.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, exposure, k20d, photography, stabilizer
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Image Stabilizer ben_mtl Pentax SLR Lens Discussion 18 05-09-2010 12:16 AM
Sigma's OS (Optical Stabilizer) + teleconverter = good? nater Pentax SLR Lens Discussion 0 10-03-2009 10:44 PM
K20D in-camera RAW conversion bug enoxatnep Pentax DSLR Discussion 0 03-15-2009 08:39 AM
Aperture 2.1.1 update fixes K20D firmware 1.01 bug? yetidesign Digital Processing, Software, and Printing 0 07-29-2008 12:59 PM
Make Your Own Image Stabilizer for $1 drexvil Pentax Camera and Field Accessories 4 02-08-2008 05:03 PM



All times are GMT -7. The time now is 10:48 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top