Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-19-2010, 09:39 PM   #1
New Member




Join Date: Aug 2010
Posts: 1
Malfunctioning K-x with teleconverter

Hi everyone, I'm a new owner if a K-x and it works great with my manual lenses, save for one Asanuma 2x teleconverter. When I use this (I'm sure it's bothering the auto contacts in some way) and try to take a picture the viewfinder blacks out for a five seconds or so, and the shutter slaps twice with no file saved in the process. At another point, when the teleconverter was in a sligthly different position, hitting any button on the camera would cause the shutter to activate, including the on/off switch. Even stranger, the lens attached to the teleconverter can access its full stopping range, but when the teleconverter and lens are attached onto the camera body, the aperture blades will move when I turn the ring, regardless of hitting the DOF preview button or not (as if it wasn't mounted to a camera) and the blades will choke up about halfway through when narrowing the aperture.

It looks like I'll just ignore that piece of equipment for now, but how it could cause such large-scale problems is pretty puzzling to me. Anyone else run into this (and is there anything that can be done about it)?

08-20-2010, 05:08 AM   #2
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
Yes, stop using the TC until you find out what is wrong. Sounds like something is bent or binding or broken. Post some pictures of the TC and maybe someone can see what is wrong.
08-20-2010, 05:15 AM   #3
Senior Member




Join Date: Jul 2008
Location: south africa, johannesburg
Photos: Gallery
Posts: 228
What can be done? Get a better TC! Even better, get a modern lens - old manual lenses are sometimes tricky to use.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, blades, button, camera, cause, dslr, k-x, lens, photography, shutter, teleconverter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! K7 malfunctioning samski_1 Pentax DSLR Discussion 9 07-11-2010 03:24 PM
Malfunctioning shutter release button... gfmucci Pentax DSLR Discussion 0 10-20-2009 08:20 PM
For Sale - Sold: Tamron 1.4x Pz-AF MC4 Teleconverter & Quantaray 2x Teleconverter DaveInPA Sold Items 15 09-24-2009 06:28 AM
Is My Computer Malfunctioning, Or Has The Forum Changed Recently?? baltochef920 Site Suggestions and Help 2 04-05-2009 01:23 PM
How do I get the most out of my 1.7x teleconverter? SouthShoreRob Pentax SLR Lens Discussion 14 01-10-2008 08:14 PM



All times are GMT -7. The time now is 04:44 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top