Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-27-2010, 06:48 PM   #1
Forum Member




Join Date: Apr 2010
Location: South Carolina
Photos: Albums
Posts: 54
Shutter release problem with my K7

Following is a short description of the problems, just in case there is a simple solution that I have overlooked:

When I try and take a picture the first time I press the shutter button all the way down the shutter appears to partially process taking a picture but it seems to stall and not take the photo. During this I can't see through the view finder and no matter how long I wait nothing happens. I have to press the button a second time to get the camera to take the photo and to reset for another photo.

Additionally the shake reduction system doesn't appear to be working.

I have my camera set to shoot in RAW and have a standard setting on just about everything on the menu. This problem happens in every mode except the Green Mode.

One thought I have is that the camera has some sort of a setting that allows for two step photo shooting where first shutter release the mirror flips and then on the second shutter button the photo takes. I am not sure where that particular feature would be hidden on the menu, but I know that I didn't change it on purpose if there is a setting for that.

I have looked through every menu on the camera and have tried everything I can think of to see if some setting has accidentily been changed that I was unaware of, but everything seems normal.

So does anybody out there have any idea if this issue is some sort of two step shutter release mode (if so how to I change it back). Or does everybody think that this is problem that needs repair.

Thanks

PS I really hope its a simple newbie thing not knowing that function. I hate looking stupid, but that's much better than a warenty repair!

08-27-2010, 07:01 PM   #2
Forum Member




Join Date: Apr 2010
Location: South Carolina
Photos: Albums
Posts: 54
Original Poster
Just wanted everybody to know that as I rethought the process I decided that whatever the issue if its a setting thing I could always reset everything and that would fix it. Well that worked. So it must have been a setting that I have no idea how to set got changed. I would still very much like to know where that setting is found.
08-27-2010, 07:55 PM   #3
Junior Member




Join Date: May 2009
Location: Charlotte, North Carolina
Posts: 27
You had the mirror lock-up drive mode on...
08-27-2010, 09:21 PM   #4
Veteran Member
kalison's Avatar

Join Date: May 2010
Location: Utah
Posts: 376
QuoteOriginally posted by Wesbo Quote
You had the mirror lock-up drive mode on...
Yep, that's exactly whet it was.

08-28-2010, 10:03 AM   #5
Forum Member




Join Date: Apr 2010
Location: South Carolina
Photos: Albums
Posts: 54
Original Poster
Got it, now what menu is that specific option on in case this happens again.
08-28-2010, 10:19 AM   #6
Forum Member
zerodaze's Avatar

Join Date: Aug 2009
Location: Arizona
Posts: 57
It isn't in the menu (accessed via the menu button). Mirror lock up is the drive mode button which is the button just above the OK button on the back. When you press it you get several drive options. Try single shot or low continuous shooting mode. And enjoy your K-7, it is one beautiful machine.
08-28-2010, 12:14 PM   #7
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by zerodaze Quote
It isn't in the menu (accessed via the menu button). Mirror lock up is the drive mode button which is the button just above the OK button on the back. When you press it you get several drive options. Try single shot or low continuous shooting mode. And enjoy your K-7, it is one beautiful machine.
That would be the option furthest left, single rectangle. Several options and drive modes disable SR because it is assumed you are using a tripod. MLU is one of these and I believe any of the remote options will also disable SR. Wireless flash disables SR as well.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, change, dslr, menu, mode, photo, photography, release, shutter, shutter release, step
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-x Shutter release? Pantingfish Pentax DSLR Discussion 9 04-23-2010 09:17 PM
Why won't my ZX-7 let me release the shutter? photolady95 Pentax Film SLR Discussion 8 06-23-2009 11:50 AM
problem with spotmatic sp shutter release button cvsuave Pentax Film SLR Discussion 3 04-21-2009 04:41 AM
Remote shutter release problem slowpez Pentax Camera and Field Accessories 10 07-29-2008 07:17 AM
Super Program problem with film advance and shutter release Laurie60014 Pentax Film SLR Discussion 6 07-18-2008 09:00 PM



All times are GMT -7. The time now is 12:18 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top