Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-30-2010, 08:28 PM   #1
Inactive Account




Join Date: Aug 2010
Posts: 2
Problems using K110d and manual lenses

I'm trying to use older K-mount manual focus lenses with a k110d. I have the "Use aperture ring" in the custom menu set to "yes". I set the camera to aperture priority. When I turn the apeture ring on the lens, it seems to have no effect on shutter speed. It's like the lens is staying at it's widest apeture. The same thing is happening with severa different lenses. The lenses appear to be working fine. I'm so desperate I actually read the manual! Any Ideas????

08-30-2010, 09:13 PM   #2
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
See the sticky thread at the top of the Beginner's forum on how to use manual lenses. Hint: Av mode doesn't work, but M mode does.
08-30-2010, 09:47 PM   #3
Inactive Account




Join Date: Aug 2010
Posts: 2
Original Poster
THANK YOU!!!
I set to manual and used the AE-L button to activate the proper shutter speed. It's working great. The manual made it sound like the camera would do it automatically in AP mode. Thanks again.
08-31-2010, 02:14 AM   #4
Ira
Inactive Account




Join Date: Mar 2009
Location: Coral Springs, FL
Photos: Gallery | Albums
Posts: 5,218
QuoteOriginally posted by sglasco Quote
THANK YOU!!!
I set to manual and used the AE-L button to activate the proper shutter speed. It's working great. The manual made it sound like the camera would do it automatically in AP mode. Thanks again.
M42 lenses will work in Aperture Priority (Av) mode, but not K lenses. (Has to do with the pin.)

However, metering isn't all that reliable in Av mode on certain cameras. My K-x way underexposes in Av, but is fine in M.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, apeture, camera, dslr, k110d, lens, lenses, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Focus problems for both manual and auto?! dkittle Pentax DSLR Discussion 32 08-20-2008 01:54 PM
HELP! manual lens problems with K10d jster91 Pentax SLR Lens Discussion 13 04-14-2008 03:41 PM
K110D Cosina manual lenses photoguy2380 Pentax DSLR Discussion 8 06-12-2007 02:19 AM
Problems with Sears 135mm f2.8 on a K110D body tasha_22 Pentax SLR Lens Discussion 4 04-16-2007 05:23 PM
Manual Lens Problems on the K10D Kemal Pentax DSLR Discussion 11 02-23-2007 02:57 PM



All times are GMT -7. The time now is 07:41 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top