Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-03-2010, 11:44 PM   #16
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
No problem. I enjoy a challenge. Unfortunately this one didn't end as desired (yet).. Good luck.

Jeff


09-05-2010, 08:24 PM   #17
Veteran Member
figmental1978's Avatar

Join Date: Feb 2007
Location: Melbourne
Posts: 789
Original Poster
I took the K10D, the DA40 & my DA*50-135 to C.R.Kennedy's (Aus Pentax supplier) service centre. Techie had a quick look and noticed that my aperture lever was very slow/sticky and needed a service anyway or a repair, so I'm getting a quote now. As to why the DA* works, it's because it has SDM and the electrics are different. We went through 5 different lenses which were DA & DFA and they all didn't stop down, then we tried other DA* lenses and they did. It's the first he's ever seen or heard of this issue so I'll update this thread with the results.
09-05-2010, 10:12 PM   #18
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by figmental1978 Quote
I took the K10D, the DA40 & my DA*50-135 to C.R.Kennedy's (Aus Pentax supplier) service centre. Techie had a quick look and noticed that my aperture lever was very slow/sticky and needed a service anyway or a repair, so I'm getting a quote now. As to why the DA* works, it's because it has SDM and the electrics are different. We went through 5 different lenses which were DA & DFA and they all didn't stop down, then we tried other DA* lenses and they did. It's the first he's ever seen or heard of this issue so I'll update this thread with the results.
I guess I'll take their word for it..

Good luck. Hope it's a simple fix and doesn't cost a fortune.

09-06-2010, 12:44 AM   #19
Veteran Member
figmental1978's Avatar

Join Date: Feb 2007
Location: Melbourne
Posts: 789
Original Poster
QuoteOriginally posted by JeffJS Quote
I guess I'll take their word for it..

Good luck. Hope it's a simple fix and doesn't cost a fortune.

Me too, he said it could cost as little as $80 up to $500. If it's the latter he said don't do it and invest in a k-x or something and use the K10D as a manual shooter. Not sure if the boss/wife will agree I'll find out the diagnosis in a few days.

09-16-2010, 04:52 AM   #20
Veteran Member
figmental1978's Avatar

Join Date: Feb 2007
Location: Melbourne
Posts: 789
Original Poster
Got a call today, damage will be about $400 AUD if I want it fixed. I think for $200 more I'd get a k-x and keep the K10D as a manual shooter.
09-16-2010, 06:20 AM   #21
Veteran Member




Join Date: Jul 2008
Location: Var, South of France
Photos: Albums
Posts: 1,071
Could it be that your K10 has a dirty Data or A contact?
Maybe SDM lenses are handled differently (by seeing that a SDM lenses is connected through the SDM contacts), and that non-SDM lenses are not seen anymore...
09-16-2010, 07:38 AM   #22
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by figmental1978 Quote
Got a call today, damage will be about $400 AUD if I want it fixed. I think for $200 more I'd get a k-x and keep the K10D as a manual shooter.
I love manual mode. Gives the most control..

09-16-2010, 02:30 PM   #23
Veteran Member
figmental1978's Avatar

Join Date: Feb 2007
Location: Melbourne
Posts: 789
Original Poster
They also mentioned they would have to replace the circuit board, hence the repair cost. I think I may have swayed my wife into just buying a k-x. That fitted with the DA40 would be a cool little camera.

09-19-2010, 09:33 PM   #24
Veteran Member
figmental1978's Avatar

Join Date: Feb 2007
Location: Melbourne
Posts: 789
Original Poster
Picked up the K10D today, C.R Kennedy (Pentax suppliers and service centre) were great and waived the repair quote fee. They also let me try any AF lens I wanted to see if they would work on the K10D to 100% confirm any lens without HDM/HSM will not work.

Unfortunately, the shop where I bought the DA40 will not let me get a cash back refund as there is nothing wrong with it which means only store credit. There is nothing else there for the $465 I paid for the DA40 anyway which pretty much forces me to buy the k-x or sell the DA40 privately. I always thought buying cameras and lenses was a fun experience, this just turned into an expensive pain the arse.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, da*, debug, dslr, f/2.8, issue, issues, k10d, mode, photography, shot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie w/ K10D issues... ahboggs Photographic Technique 4 06-14-2010 11:13 AM
K10D + HSM issues tigereye Pentax SLR Lens Discussion 5 05-09-2009 04:36 PM
K10D going in for BF issues pentkon52 Pentax DSLR Discussion 7 03-03-2008 09:50 PM
K10D AF issues................. hudsong Pentax DSLR Discussion 20 02-22-2008 12:50 PM
K10d issues; how much do you believe? Takman Pentax DSLR Discussion 84 11-06-2007 05:19 AM



All times are GMT -7. The time now is 01:06 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top