Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-02-2010, 03:35 AM   #1
New Member




Join Date: Sep 2010
Posts: 1
Light sensor problem on DL2?

Hi, I am new and have a problem with my beloved camera. It's about 4 years old now, but still takes great pictures when it's working properly. I have a problem now though, possibly with the light sensor. I am a complete camera dunce really, and usually use the Auto settings, occasionally having a little play, but I don't know what I am doing. All my pictures are coming out dark though, REALLY dark. You can just about make out what they are if you really squint, but that's it. It's not all the photos though, it'll work intermittently, for about 2-3 pictures and then go back to the dark ones. A friend managed to get it working manually, but not on auto.

Has anyone come across this problem? I am guessing it needs to go back to Pentax, but with it's age etc, I wonder if it'll be economical to repair. I've updated the firmware, to no avail.

09-02-2010, 05:40 AM   #2
Senior Member
AOShep's Avatar

Join Date: Feb 2010
Location: Eastern PA
Photos: Gallery | Albums
Posts: 293
Have you checked your lens? Possibly un-mount and re-mount to make sure it is on secure. If you have other lens you can even try mounting another lens. Try to fine turn your troubleshooting so you can be fairly confident where the problem is.
09-02-2010, 08:39 AM   #3
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
It would help to post a picture you are having problems with, and make sure not to remove the EXIF information before posting. Could be something as simple as you having dialed in negative exposure compensation?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, camera, dslr, light, light sensor, photography, pictures, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sensor Problem kirstenincanada Pentax DSLR Discussion 17 04-28-2010 10:07 AM
Another spots on sensor problem. photolady95 Troubleshooting and Beginner Help 11 02-24-2010 04:56 PM
pentax k-x sensor problem mRo Troubleshooting and Beginner Help 11 12-10-2009 05:35 PM
Does my sensor have a problem? amaurosis Pentax DSLR Discussion 7 08-17-2009 05:31 AM
*ist DL2 focusing problem dseang Pentax DSLR Discussion 4 02-02-2007 10:28 AM



All times are GMT -7. The time now is 03:34 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top