Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-05-2010, 08:52 PM   #1
New Member




Join Date: Sep 2010
Location: Denver, Colorado
Posts: 2
istDS not working, making clicking sound

My 2005 istDS is suddenly not working. I was surprised to see that the batteries needed changing since I recently put in new ones. Once I changed the batteries the digital panel lit up again but it will not take a picture, instead all I hear is a fast clicking sound. I've tried manual focus and a different lens, but I get the same result each time. As far as I know the camera has just been sitting on the counter since I used it about a week ago.

Any ideas?

Thank you!
Sara

09-05-2010, 08:59 PM   #2
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
Sara, Welcome to the forums (first of all)..

Are you the original owner of this camera? Try taking the lens off and looking in while you press the shutter release. Does the Mirror flip up? From there, put the camera in B, try it again, you should see the mirror flip up and the sensor become exposed. If neither of those happen, it may be time to retire the camera for a newer one. This sounds like a mechanical problem to me and the cost of fixing it may be prohibative.

09-05-2010, 11:20 PM   #3
Veteran Member
inferno10's Avatar

Join Date: Feb 2007
Location: San Francisco, California
Posts: 342
With the camera off, hold the menu button while flipping the power switch on. Does the screen come up with the firmware version? If not, something's wrong with your firmware and you'll have to send it in for service.

If it does come up, try reinstalling the firmware and see if that resolves the issue.

- Jason
09-06-2010, 06:30 AM   #4
New Member




Join Date: Sep 2010
Location: Denver, Colorado
Posts: 2
Original Poster
Thank you both for your help. Yes, I'm the original owner of the camera. I tried both tips above -- the firmware update didn't help and the mirror does not flip up -- ever. Now I'm beginning to get worried! Thanks for your help.

09-06-2010, 06:59 AM   #5
Site Supporter




Join Date: Oct 2006
Location: Dayton, OH
Photos: Gallery
Posts: 4,155
Try leaving the batteries out of the camera for at least 24 hours. You will have to reset the date and time after this but it might "reboot" your system.

Us DS people have to stick together. Good luck.

Tim
09-06-2010, 01:55 PM   #6
New Member




Join Date: Apr 2009
Posts: 8
QuoteOriginally posted by saharablue Quote
instead all I hear is a fast clicking sound. I've tried manual focus and a different lens, but I get the same result each time.
Sounds a lot like my problem with my K200D. It was related to temperature. Too cold, and instead of taking pictures it just started clicking. It got gradually worse and would at the end only take pictures when heated to living room temperature.

I got mine fixed under warranty.

Asbjørn
09-07-2010, 09:26 PM   #7
Oro
Junior Member




Join Date: Aug 2010
Location: Seattle-ish, USA
Photos: Gallery | Albums
Posts: 41
What batteries did you install? The correlation with problems and new batteries should be the first thing you rule out. I have read/heard here on the forum of slightly sub-standard batteries causing ills. Did you put in fresh CRV3's or NiMH rechargeables with a full charge? If not, I'd do one of those two things after letting it sit w/o batteries for a period.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, dslr, istds, photography, sound
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-x making sound in longer exposure. Is it normal??? gut1kor Troubleshooting and Beginner Help 2 07-17-2010 09:37 AM
Clicking sound on my new 12-24 F4 DA kuau Pentax SLR Lens Discussion 6 01-05-2009 09:34 PM
Clicking sound from the lens - loose parts? lockheed Pentax SLR Lens Discussion 3 06-26-2008 07:17 PM
Flash not working with istDs Karl Inge S Flashes, Lighting, and Studio 3 12-17-2007 10:54 AM
K100D making "static" sound breischl Pentax DSLR Discussion 17 11-18-2007 08:17 AM



All times are GMT -7. The time now is 04:25 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top