Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-11-2010, 02:12 PM   #16
Pentaxian
jeffshaddix's Avatar

Join Date: Jun 2010
Location: Albuquerque, NM
Posts: 1,371
Yeah I had my front e-dial fail too, 3 days after receiving it! CRIS fixed it fine and within warranty...no worries except for the 2.5 week period with no camera.

11-13-2010, 06:20 AM   #17
wll
Veteran Member




Join Date: Nov 2006
Location: Mission Hills, CA
Posts: 773
QuoteOriginally posted by bmf Quote
I made the HUGE jump from my trusty Z1P to the K7 - what a let down!

My dial does not work either.

It seems this is really common.

c'mon Pentax

Lets hope they fixed this problem with the K-5 !


wll
12-04-2011, 05:40 PM   #18
bmf
Junior Member




Join Date: Nov 2010
Posts: 38
Damn, not even a year since CRIS replaces my front e-dail and today it goes belly up again....... I will let the forum know Pentax's warranty on their warranty repairs. It seems more and more this will become an issue.

Lets hope we do not have to discover the warranty period on warranty repairs of warranty repairs.

*Very disappointed* - And I was just about to splash out a thousand bucks on a FA 31, I am now questioning my whole Pentax system. I am glad this happened before I bought the 31!

BMF
12-10-2011, 05:45 AM   #19
New Member




Join Date: Mar 2010
Location: Antipolo Rizal Philippines
Posts: 11
A few squirts of contact cleaner to the e-dial and you're good to go. I've done this with my k-7 rear e-dial.
Some KR and older pentax dslr users can attest to that.
https://www.pentaxforums.com/forums/pentax-k-r-forum/138906-pentax-k-r-e-dial.html

05-14-2014, 10:34 AM   #20
Junior Member
a14onymus's Avatar

Join Date: Jan 2011
Location: Bucharest
Posts: 35
Hello,I haven't seen any recent activity on this thread.Recently I observed that i have this issue with the dial button and also with the green button.So now my iso changes very fast from 200 - 1600,and also when I try to zoom in ,it fast forwards to the maximum zoom option.I bought the Pentax K 7 in 2009 and since then I hadn't a single problem with it.I thought in the first place that it is a software bug but after updating the firmware and reseting the camera there is no change,it's still buggy.I've read all the comments and I would like to know if it is possible how much did it cost at the service because I'm sure there is no waranty now,and also if anyone can tell me how long do they keep the camera in service.Thank you.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, click, dslr, e-dial, k7, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front to Back Sharpness: Distance setting on front of lens yoon395 Troubleshooting and Beginner Help 18 09-08-2010 04:33 PM
Front dial intermittent issue on the K20D jpzk Pentax DSLR Discussion 8 09-03-2010 05:37 PM
Faulty equipment or faulty photographer? (K-x) mamba909 Pentax DSLR Discussion 22 02-15-2010 12:16 PM
Faulty FA 80-320 EsBee Pentax SLR Lens Discussion 10 08-28-2009 06:49 PM
Faulty SD card. Bramela Pentax Camera and Field Accessories 10 01-20-2009 12:39 PM



All times are GMT -7. The time now is 07:30 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top