Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-04-2007, 01:00 AM   #1
Inactive Account




Join Date: Jul 2007
Location: Virginia
Posts: 141
Cleaning K10D Sensor with Eclipse

Does anyone use the original Eclipse to clean their K10D's sensor? Ive been searching different forums on this topic and haven't found much info... Most sites say that E2 is recommended for the K10D's sensor because of the coated sensor... I have found one or two post that claim Eclipse can be used on coated sensors with no harm... I have been using the original Eclipse with a pecpad to swab the sensor in my k10d when needed and haven't seen any adverse side effects because of this... If anyone has any knowledge on the topic of Eclipse vs E2 for coated sensors please do share!

09-04-2007, 08:53 PM   #2
Inactive Account




Join Date: Jul 2007
Location: Virginia
Posts: 141
Original Poster
i posted this at dpreview as well and got some info i thought id link incase anyone else was interested.... Cleaning K10D Sensor with Eclipse instead of E2 [Page 1]: Pentax SLR Talk Forum: Digital Photography Review
09-05-2007, 01:39 AM   #3
axl
Veteran Member




Join Date: Mar 2007
Location: Nove Zamky, Slovakia
Photos: Gallery | Albums
Posts: 7,181
I've been using Eclipse on my K100D. Haven't noticed any harm to it.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, e2, k10d, photography, sensor, sensors, topic
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cleaning with Eclipse drjaxon Pentax SLR Lens Discussion 7 03-31-2009 04:51 PM
sensor cleaning for k10d chicochongchu Pentax DSLR Discussion 16 02-03-2009 11:35 PM
Automatic Sensor Cleaning in k100d Super and k10d superfuzzy Pentax DSLR Discussion 3 11-19-2007 04:18 PM
Sensor cleaning: Pec-Pads or Sensor Swabs gadgetnu Pentax Camera and Field Accessories 29 09-24-2007 10:52 AM
Weird Sound of K100D (K10D 2?) in B/Sensor Cleaning Mode RiceHigh Pentax DSLR Discussion 13 01-05-2007 07:01 AM



All times are GMT -7. The time now is 05:18 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top