Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-19-2010, 08:41 AM   #1
Forum Member




Join Date: Sep 2010
Posts: 51
K-7 starts then immediately turns off

Hi all,

First time poster here. My 3-month old K-7 all of a sudden will not work for no apparent reason. It powers up, then I hear a faint mild "whoosh" (not sure I've hear this before), then it shuts off immediately. The camera was working fine only minutes before and nothing seemed out of the ordinary. I put in a fresh battery but still get the same result. Any ideas as to what might be going on? Thanks!

09-19-2010, 09:22 AM   #2
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,482
I have not experienced such a problem, but I would recommend first a few suggestions:
(1) Recharge fully your battery;
(2) Use a Pentax battery 100% charged;
(3) Update your firmware;

Then:
(4) Take out the SD card, and try to power up the camera without the SD card.

If this works:
(5) Try another SD card.

I remember a post in which a Pentaxian had some pb that seemed related to the card; use a good quality card (like a Sandisk Extreme III) newly reformatted.

Hope that the suggestions will help.
09-19-2010, 09:33 AM   #3
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,873
The camera turns itself off when there is not enough battery power. Check you battery, (is this the genuine k-7 battery that comes with the pack?), if one does not work, try another one.
09-19-2010, 09:50 AM   #4
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by hcc Quote
I have not experienced such a problem, but I would recommend first a few suggestions:
(1) Recharge fully your battery;
(2) Use a Pentax battery 100% charged;
(3) Update your firmware;

Then:
(4) Take out the SD card, and try to power up the camera without the SD card.

If this works:
(5) Try another SD card.

I remember a post in which a Pentaxian had some pb that seemed related to the card; use a good quality card (like a Sandisk Extreme III) newly reformatted.

Hope that the suggestions will help.
I wouldn't be touching the firmware in this situation, At ALL. If the camera randomly shuts down during the update, K7= $900 brick paperweight. He's stated that his batteries are fully charged (I don't see why people feel the need to tell someone who has made that assertion, to charge their batteries). The card however, could be at issue. That's the direction I would go and then off to service under warranty.

Don't waste a lot of time screwing around with it and getting more frustrated. Try the simple stuff then pack it up and send it in.



09-19-2010, 10:19 AM   #5
Forum Member




Join Date: Sep 2010
Posts: 51
Original Poster
Thanks to all of you. Problem solved - I recharged the battery, put in a new SD card and all is well now.
09-19-2010, 10:24 AM   #6
Veteran Member




Join Date: Mar 2010
Photos: Gallery | Albums
Posts: 1,545
It sounds like the little button in the card compartment isn't pressed in all the way... Is your card door closed?
09-19-2010, 11:49 AM   #7
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by wjax Quote
Thanks to all of you. Problem solved - I recharged the battery, put in a new SD card and all is well now.
So, after my rant , I'm curious. Was it the battery or the card, or don't you know?

09-19-2010, 01:13 PM   #8
SPB
Senior Member
SPB's Avatar

Join Date: Jan 2008
Location: Zug
Photos: Gallery | Albums
Posts: 132
Sounds more like the door for the card enclosure wasn't properly closed.

09-19-2010, 02:22 PM   #9
Forum Member




Join Date: Sep 2010
Posts: 51
Original Poster
QuoteOriginally posted by JeffJS Quote
So, after my rant , I'm curious. Was it the battery or the card, or don't you know?

Hi Jeff,

After further review, I think it was the card door or improper seating of the card in the slot. I think the door may not have been latched properly since I am able to recreate the problem by reloading the card and leaving the door all the way open. The battery that I thought might be dead seems to have a good charge so that would appear to eliminate that as a problem. Thanks again for your help on this.
09-19-2010, 03:47 PM   #10
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,052
The card door for sure does it. Never tried that before.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-7, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K100D Powers down immediately akaharry Pentax DSLR Discussion 5 07-31-2009 05:22 PM
Red gladiloa turns orange photolady95 Photo Critique 17 07-16-2009 09:39 AM
Splash - accidents turns out better? thomascdk Photo Critique 8 06-05-2009 11:00 PM
Discoloration, bright yellow turns red StarDust Photographic Technique 13 05-29-2008 01:01 PM
K10D LCD turns off prematurely & at random? jvp Pentax DSLR Discussion 25 03-27-2008 11:49 PM



All times are GMT -7. The time now is 03:34 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top