Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-05-2010, 11:23 AM   #1
Site Supporter




Join Date: Aug 2007
Location: Canada
Photos: Gallery
Posts: 165
K7 SD slot problems - never had this issue b4?

Hi,
This is a repost from a K7 Card slot thread that I had posted in later than everyone else and i'm not sure anyone has seen it so here goes:

I've had my K7 for months now and previous to today, any SD card just popped out perfectly. No issues whatsoever.

But for some reason, 2 issues started happening.

1. the lexar platinum II sdhc 4 class card which I've used exclusively in this camera since i got it, goes in perfectly. Pops out perfectly. BUT can NOT be formatted or 'read' by the camera. When I snap a pic, I get the "no card in the camera' message.

2. if I put in ANY other SD card, not only do they work, but they also get incredibly jammed in the slot. I have to use something else to jam the edge of the card so it goes down to activate the popping mechanism and then it doesn't pop all the way - I have to use my fingernails to pull it out.

So, to me, it's almost as if the K7 isn't reading the Lexar card b/c it's not inserted properly. Otherwise, why does it pop out perfectly while the others don't and they are the ones which can be used?

This card does work in my Canon SD1200 and my drift innovation headcam (although it does record an annoying beeping sound throughout the audio - i'm thinking it's b/c I'm shooting 1080P and the 4 class just can't handle it). I tried the newer lexar professional class 10 card I got for the drift HD170 and the audio is perfect (again, this card works in my K7, but gets 'stuck' ).

Unless, something is screwed up with the lexar 4 class card?

To reiterate again, prior to this day, no card EVER got stuck in my camera. I haven't dropped it or anything. I just don't understand.

Cheers,
keebler


Read more at: https://www.pentaxforums.com/forums/pentax-dslr-discussion/102387-k7-secure-d...#ixzz11VfxntyK

10-05-2010, 01:35 PM   #2
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,103
Look at the side of your Lexar card and see if the plastic lock switch is still on it. I know this is a stretch, but if that little part were stuck in the camera it could explain why that card will go in, but the others won't. i.e. their lock switches jamming against the one from the other card that is stuck inside. Just grasping at straws here.
10-05-2010, 02:12 PM   #3
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,312
also try re-formatting it, and also look at the littke ridges between the contacts

I noticed some of these falling off my cards, they can get caught and mess up the contacts
10-06-2010, 11:17 AM   #4
Site Supporter




Join Date: Aug 2007
Location: Canada
Photos: Gallery
Posts: 165
Original Poster
Thanks folks. I guess it took another set of eyes for someone else to realize the top part was slightly broken. Lifetime warranty so I have a new card.

So that's part 1 of my issue, but the other part is why cards (including this new one) are still getting stuck when they never did before.

I sent an email to Pentax and am curiously waiting for what they have to say.

interesting...

Thanks again!
Keebler

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, class, drift, dslr, k7, lexar, photography, pop, sd, slot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
SD card slot on the K5 jpzk Pentax K-5 36 11-24-2010 08:11 PM
K7 SD-slot Daan Pentax DSLR Discussion 27 10-03-2010 06:21 PM
New K-7 : SD Slot issue or normal thing? sagar Pentax DSLR Discussion 5 04-21-2010 10:24 AM
Landscape Slot Canyon Marc Langille Post Your Photos! 7 10-31-2009 07:16 AM
Slot Canyons (several pictures) clawhammer Post Your Photos! 18 01-13-2009 07:41 AM



All times are GMT -7. The time now is 05:23 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top