Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-09-2010, 03:26 AM   #1
Junior Member




Join Date: Dec 2009
Photos: Albums
Posts: 38
K20D get stuck on playback mode

Hi All,

Today I have some strange issue with my K20D, which I don't know if it's related to the camera or to the SDHC card.
I've bought me a new (old) SMC Pentax-A 35-70 (very nice piece of glass), so I spend some time with it at the last few days.
Today I took some pictures with it (indoor using the Metz 58), and at some point, after taking a picture of my daughter, I switch to the playback mode, so the last picture I took was shown, and then the camera just froze! I've tried to go to other photo, press the shutter button, tried to cancel the playback mode – nada, nothing works, even the dials seams to do nothing.
I switched the camera off, and I saw that the photo stay on the screen for about 2 second and then the LCD turn off (maybe there was some energy left, so no problem).
I took the battery out, wait a minute or two, switch the camera on, go to playback mode and again - the camera get stuck! So switching it off again, then on, taking some more pictures and go to the playback mode again – all was good, but when I paged through the photos, once I get to the picture that arise the issue – the camera froze again!
So again off-on the camera, going to playback mode (and see the last good picture), use the dial to enter to the multi-image display mode, select the 'bad' picture, delete it, and from then on I have no such issue.
The only action I didn't take was to take the card out and see if there is still the same problem.
The card is SanDisk SDHC class 2 4GB, the camera have the latest firmware.
Did any of you have the same problem? Is it a camera issue or, more likely, a crad issue?
Thanks,
Yaniv

10-09-2010, 07:32 AM   #2
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,888
Sounds like a bad sector on the memory card. It could be failing.
10-09-2010, 09:29 AM   #3
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
I hope the photo of your daughter wasn't one of those once in a lifetime shots. Sounds like the card is heading south. Try reformatting it after you get your photos off of it (and start looking for a new card, this will only get worse if it's the card).

10-09-2010, 01:00 PM   #4
Junior Member




Join Date: Dec 2009
Photos: Albums
Posts: 38
Original Poster
Fortunately the picture that froze the camera was not one of a life time…
I've format the card, took some pictures with it, and so far there is no problem with it. In any case I'll buy another card, just in case, and will use the old one as a backup.
One note though – after reading the ETTR tutorial, and some threads about using the AF button instead of the shutter button I started to use the AF button, so after I got the issue with the stuck photo, I switched to the kit lens, and as I was worry about the camera failure I forgot to use the AF button, and get more worry why the hell the camera stop focusing… it took some photos and some heart beating until I realize that I should use the AF button…

10-10-2010, 07:09 PM   #5
Site Supporter




Join Date: Jul 2008
Location: Detroit MI, USA
Posts: 502
QuoteOriginally posted by goldenzebra Quote
Fortunately the picture that froze the camera was not one of a life time…
I've format the card, took some pictures with it, and so far there is no problem with it. In any case I'll buy another card, just in case, and will use the old one as a backup.
One note though – after reading the ETTR tutorial, and some threads about using the AF button instead of the shutter button I started to use the AF button, so after I got the issue with the stuck photo, I switched to the kit lens, and as I was worry about the camera failure I forgot to use the AF button, and get more worry why the hell the camera stop focusing… it took some photos and some heart beating until I realize that I should use the AF button…
Can't hurt to ask. Do you have the latest firmware. The last firmware fixed an issue with SD cards (affects several Pentax dSLRs) and a firmware was released not too long ago. I would make sure.

Link to your K20D firmware
Latest K20D Firmware Update : Software Downloads : PENTAX
10-11-2010, 02:48 AM   #6
Junior Member




Join Date: Dec 2009
Photos: Albums
Posts: 38
Original Poster
Yep, I've got the latest firmware

QuoteOriginally posted by jamesm007 Quote
Can't hurt to ask. Do you have the latest firmware. The last firmware fixed an issue with SD cards (affects several Pentax dSLRs) and a firmware was released not too long ago. I would make sure.

Link to your K20D firmware
Latest K20D Firmware Update : Software Downloads : PENTAX
The firmware is up to date (as I mentioned at the first post).
For now there is no problem with the card, since I format it, but, as I said before, I'll buy a new one (they are so cheap), and save the old one as a backup.
Thanks any way!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, dslr, issue, k20d, mode, photo, photography, picture, playback, sdhc, switch
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Mode Dial stuck? chriiisty Troubleshooting and Beginner Help 6 03-14-2011 01:05 AM
K10D Stuck in AV mode mpodesta Pentax DSLR Discussion 10 04-27-2010 10:49 AM
K-7 movie mode playback Stephanus Video and Pentax HDSLRs 3 04-10-2010 02:09 PM
T-mount adaptor stuck on my K20D...not this next week! imtheguy Pentax SLR Lens Discussion 23 09-18-2009 02:50 PM
K100D stuck in Tv mode ToddM Pentax DSLR Discussion 5 08-27-2009 07:19 PM



All times are GMT -7. The time now is 06:46 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top