Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-12-2010, 10:24 AM   #16
Veteran Member
Squier's Avatar

Join Date: Apr 2009
Location: Oxfordshire UK
Photos: Albums
Posts: 707
Original Poster
Ok, dont understand this, but the numbers have appeared, and i havent changed anything since I turned " Display Sensitivity " off

I just simply turned the camera on again, and there they were, but this time, i had the 18-55 Kit Lens on



10-12-2010, 10:28 AM   #17
Veteran Member
Squier's Avatar

Join Date: Apr 2009
Location: Oxfordshire UK
Photos: Albums
Posts: 707
Original Poster
Without changing ANY settings anywhere, i swapped the kit lens over for my MF Tamron 90mm, and the numbers simply disappeared.

Actually, there's nothing there now except these - - -
10-12-2010, 12:25 PM   #18
Veteran Member
Squier's Avatar

Join Date: Apr 2009
Location: Oxfordshire UK
Photos: Albums
Posts: 707
Original Poster
Discovery ..

These metering numbers only appear automatically with the Kit lens mounted, using M mode. And yes, the numbers will adjust from + 3 -2 etc depending where you point the lens / changing light. Excellent

Soon as a manual lens is mounted, they disappear. In M mode, the EV button has to be pushed, the metering number appears but it doesnt change when moving the lens about. Its just there to dial some EV in, so you dont know if you are over or under exposing, like with the Kit lens

I'm probably missing some tricks here, this being a new camera to me
10-12-2010, 12:37 PM   #19
Veteran Member
ytterbium's Avatar

Join Date: Jan 2008
Posts: 1,076
I just checked with camera.

Indeed. I also have the F-- in manual mode and only the shutter speed can be changed (or changes by green button press).
Now if i stop the lens down (use optical preview lever) the numbers appear and change as i move the lens around.
This is a M type lens.
Probably with m42 lens you have to manually stop it down, set shutter speed and then use the optical preview to activate stop down metering and live EV reading.
Now i understand how your described K10D behavior would be nice - meter working in stop down mode all the time.

10-12-2010, 12:49 PM   #20
Veteran Member
Squier's Avatar

Join Date: Apr 2009
Location: Oxfordshire UK
Photos: Albums
Posts: 707
Original Poster
Sorry - i got it back to front. With a manual lens, mode dial has to be AV, not M. The metering numbers will appear in AV, but only after pushing AV button. But they dont change while moving the camera about

No metering numbers appear at all in M mode, whether pressing AV or Green buttons. Also, Green Button does nothing in M mode either.

..so best to set custom function for Green button. Oops

Last edited by Squier; 10-12-2010 at 01:20 PM.
10-12-2010, 01:30 PM   #21
Veteran Member
ytterbium's Avatar

Join Date: Jan 2008
Posts: 1,076
Did you also tried the optical preview lever? It shows the numbers for me.

Green button must be set up properly to do something.
10-12-2010, 01:37 PM   #22
Veteran Member
Squier's Avatar

Join Date: Apr 2009
Location: Oxfordshire UK
Photos: Albums
Posts: 707
Original Poster
I tried Opt. Pre. and i got nothing. I guess this is down to a setting in the Cus. Func. like you say


They only way ( with a manual lens ) i can get any metering numbers up, is to use AV mode, and press AV button to make them appear, but the numbers will not change to suit the lighting as I move the camera around.
10-12-2010, 03:11 PM   #23
Junior Member




Join Date: Jul 2008
Location: Pa.
Posts: 27
Page 94 in manual. The pic. on 95 is the top LCD but look in viewfinder and turn dial and number on right by hand will change. Put a manual lens on camera and set to A. Set camera to M mode. In the middle of display there are two numbers one is underlined that is speed press AV button and line moves to Aperture now buy changing either one the numbers by hand will change when at 0.0 all set.


Last edited by gherrm; 10-12-2010 at 03:25 PM. Reason: spelling
10-12-2010, 03:47 PM   #24
Veteran Member
Squier's Avatar

Join Date: Apr 2009
Location: Oxfordshire UK
Photos: Albums
Posts: 707
Original Poster
That is not what i see with a manual lens. Thats what i see with an AF lens.

If i mount a manual lens, use M mode like you say, set camera to A

I see this...

250 F --- ---

If I press AV, nothing happens at all.
10-12-2010, 03:53 PM   #25
Junior Member




Join Date: Jul 2008
Location: Pa.
Posts: 27
Menu- C custom setting # 14 change to 2 Green button in manual
10-12-2010, 04:00 PM   #26
Veteran Member
Squier's Avatar

Join Date: Apr 2009
Location: Oxfordshire UK
Photos: Albums
Posts: 707
Original Poster
Ok, done that Gherrm, Green button No.2 = TV shift

what about the E-Dial setting, does that have any influence on the metering numbers ?
10-12-2010, 04:08 PM   #27
Junior Member




Join Date: Jul 2008
Location: Pa.
Posts: 27
Reread my post # 23. When you turn dial those numbers (the one underlined) will change. and so will meter.
10-12-2010, 04:14 PM   #28
Veteran Member
Squier's Avatar

Join Date: Apr 2009
Location: Oxfordshire UK
Photos: Albums
Posts: 707
Original Poster
yes i got that now, as long as i have Optical Preview lever enaged, i can see metering numbers changing as i move the camera lens.

So, what about the E-dial setting in Cust Func.. Does that affect anything ?

E-dial In Program

1 Program shift
2 Tv
3 Av
4 off
10-12-2010, 04:26 PM   #29
Junior Member




Join Date: Jul 2008
Location: Pa.
Posts: 27
Custom setting I have 13-1 18-2 23-2 6-2 7-2 9-2
14 green button you do not have to ever change leave on 2
10-12-2010, 04:30 PM   #30
Junior Member




Join Date: Jul 2008
Location: Pa.
Posts: 27
As for changing the other settings it gets to deep for me. Maybe when I get better and understand it better then I will.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bar, camera, canon, dslr, k200d, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Struggling with metering, k200d ytterbium Troubleshooting and Beginner Help 14 04-08-2010 12:07 AM
K200d: Incorrect metering in low light conditions? flamenco Pentax DSLR Discussion 29 11-28-2009 02:50 AM
Does the K200D metering tend to favor the right side of the histogram? joeyc Pentax DSLR Discussion 7 06-26-2009 12:06 PM
k10D metering with M lenses in M mode - K200D doing a better job w/ Green button mrpackerguy Pentax DSLR Discussion 8 10-03-2008 11:53 AM
What I miss (and don't miss) about my K10D switters Pentax DSLR Discussion 35 01-06-2008 02:51 AM



All times are GMT -7. The time now is 06:11 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top