Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-02-2010, 06:24 AM   #1
Veteran Member




Join Date: Nov 2009
Location: Iowa
Photos: Albums
Posts: 2,269
Weird mirror lens metering issue

Hi.

My wife has a cheap Kalimar 500mm mirror lens that she uses on her *ist-D. When using the lens, the metering works fine on her *ist-D, but when I use it with my K-100D, the metering is consistently underexposed by a couple of stops. All other lenses work fine on my K-100D.

Anybody got an explanation why this might be happening? Has anyone else here used a mirror lens successfully on a K-100D?

I was kind of surprised it would work properly on one body & not the other, since they're both basically the same camera.

Cheers,
Bob :-)

11-02-2010, 08:32 AM   #2
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
some cameras seem to like having pin 7 of the mount shorted, this is the data pin, otherwise they meter funny. Is the lens painted or anodized at the mount point"
11-02-2010, 10:59 AM   #3
Pentaxian




Join Date: Feb 2009
Location: Alameda, CA
Posts: 3,198
QuoteOriginally posted by GibbyTheMole Quote
...since they're both basically the same camera.
They're not

The metering problem with manual lenses is well-known with Pentax K-xxD and K-xxxD bodies. *ist series did not have this problem. In fact, one way to fix the metering problem with K10D and K20D is to replace the stock focusing screen with one for the *ist series. The K-7 is better but still not perfect.

If your camera doesn't have user-replaceable focusing screen, you'll have to learn to adjust accordingly.
11-03-2010, 05:26 AM   #4
Veteran Member




Join Date: Nov 2009
Location: Iowa
Photos: Albums
Posts: 2,269
Original Poster
I don't think there are any pins on the lens mount, since it's a T-mount lens with a Pentax adapter.

Not a big issue, tho... I can just use +2 stops exposure compensation when I use that lens.

Thanks,
Bob :-)

11-03-2010, 05:53 AM   #5
Pentaxian
ovim's Avatar

Join Date: Sep 2008
Location: Tre, Finland
Photos: Gallery
Posts: 1,227
QuoteOriginally posted by GibbyTheMole Quote
I don't think there are any pins on the lens mount, since it's a T-mount lens with a Pentax adapter.

Not a big issue, tho... I can just use +2 stops exposure compensation when I use that lens.

Thanks,
Bob :-)
He meant the contacts on the body. Place a piece of tin foil between the lens and the contacts so that they are shorted. That should help.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
*ist-d, camera, dslr, k-100d, lens, mirror, mirror lens, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help - Metering issue neoyoda Pentax DSLR Discussion 7 09-18-2010 12:52 PM
Weird issue with SR on K-7 joshnl Pentax DSLR Discussion 0 11-26-2009 04:23 PM
ZX-M metering issue LMRacing Pentax Film SLR Discussion 5 09-13-2009 07:41 PM
Weird AF-540FGZ underexposure issue richg35 Pentax Camera and Field Accessories 6 12-26-2008 12:05 PM
Weird focus issue. dwinnert Pentax DSLR Discussion 8 05-24-2007 12:25 AM



All times are GMT -7. The time now is 07:38 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top