Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-18-2010, 04:31 AM   #1
New Member




Join Date: Dec 2009
Posts: 6
K100d issues

Hi everybody. I've had a k100d for about 3 years and it got destroyed by a 4 year old and some concrete I bought a new one on ebay that said it had been barely used and it's arrived, and I'm inclined to believe them, it's spotless, in the original packaging. However, when I turn it on, there's a very quick clunkclunk which definitely didn't happen with my old one. I can feel something move when I turn it on.

also, it seems slightly predisposed to make images have a quite severe blue tint. Have I got a dodgy one?

11-18-2010, 04:38 AM   #2
New Member




Join Date: Dec 2009
Posts: 6
Original Poster
ah, managed to fix the blue issues, it was just a setting that needed changing. The noise is worrying me though.
11-18-2010, 04:51 AM - 1 Like   #3
Senior Member
RubyT's Avatar

Join Date: Sep 2008
Location: TN
Photos: Gallery
Posts: 279
Check and see if it is set to run dust removal on start-up. My K100DS does make a "clunk clunk" when I run the dust removal.
11-18-2010, 05:43 AM   #4
New Member




Join Date: Dec 2009
Posts: 6
Original Poster
oh THANKYOU! Yes that's what it was! Fantastic!

11-18-2010, 01:12 PM   #5
Veteran Member




Join Date: Apr 2010
Location: PGH PENNA
Posts: 340
I thought the K100d didn't have dust removal or am I missing something
11-18-2010, 01:15 PM   #6
Junior Member




Join Date: Jun 2009
Location: Atlanta
Posts: 37
QuoteOriginally posted by JACOBY Quote
I thought the K100d didn't have dust removal or am I missing something
I would guess his replacement was the 'Super' version which added dust removal.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k100d, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K100D Issues with Batteries but maybe more than that. Sunniebgi Pentax DSLR Discussion 17 09-04-2009 07:29 PM
Traditional KA Lens on K100D - Issues? Russell W. Barnes Pentax DSLR Discussion 1 05-02-2009 04:20 AM
k100d battery issues rjburgos Troubleshooting and Beginner Help 31 03-26-2009 07:16 PM
K100D Super focus issues shesweet59 Pentax DSLR Discussion 11 01-10-2009 03:06 PM
K100D Issues: Three of them gnaztee Pentax DSLR Discussion 7 12-03-2007 08:45 PM



All times are GMT -7. The time now is 07:01 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top