Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-22-2010, 04:29 PM   #1
Inactive Account




Join Date: Nov 2010
Location: Flint
Posts: 2
Pentax K-X & Using hot shoe sync with strobes

I am really new to using monolights/studio lighting/strobes, etc. I attach a sync cord to my camera using a hot shoe adapter (hope I am calling it the right thing!). I shoot manual exposure, and sometimes after setting my camera to the properly metered settings using a light meter, focus, press the shutter, etc., the strobe does not fire. I am trying to figure out why sometimes the strobe fires and sometimes not. Someone suggested that the camera won't trigger the flash unless it's above the camera's flash sync speed....

... Can anyone help? And if anything I said is not clear or doesn't make sense, please let me know. I am admittedly new to using studio lighting as I typically work with available light.

Thank you!

11-23-2010, 01:47 PM   #2
Pentaxian
hoanpham's Avatar

Join Date: Nov 2009
Location: Strand
Photos: Gallery | Albums
Posts: 1,360
I had a cable fault once. Above 1/180 wont be able to fire at all from hotshoe or x-synch. Set all to manual and try to 'debug' systematically, ie minimize faulty sources (hotshoe direct, new cable...)
11-23-2010, 02:53 PM   #3
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,043
PC cables are the bane of a studio photographers existence.
A couple of things to try.
One is to squeeze the PC contacts together ever so slightly so that it grabs the PC socket quite snugly and give it a few good twists back and forth when you plug it in to clean any corrosion off the contacts.

One odd think I've noticed about Pentax cameras is that the polarity of their PC socket is reversed, so i presume that the same holds true for the hot shoe.
With our Norman power packs, i have to reverse the leads from camera to box to make the flash fire.
In this scenario, If I turn the camera off and back on, it will fire the strobe one, and then not again until I turn the camera off and then on again.
This doesn't sound like your problem, you sound like you have a bad electrical contact going on.
As an aside, and this is actually pretty important, make sure you are using a "Safe-Sync" type of adapter if you are running a power pack off of a hot shoe. Studio flash units can have quite a high trigger voltage. I suppose you might even be tripping an internal circuit breaker.
01-19-2011, 10:03 PM   #4
New Member
prairiegal's Avatar

Join Date: Jan 2011
Location: www.wendysawatzky.com
Posts: 1
I'm having the problem Wheatfield described above with a pair of Impact EX100As and my KX.

When I connect the strobe's sync cable to the camera with an SM-601 hotshoe adapter, the strobe will fire once, but then it won't fire again unless I unplug the sync cable and plug it back into the adapter (or turn the strobe on and off). Also the "test" button on the strobe doesn't fire if I push it; it needs to be pushed twice to start firing again.

If I leave off the sync cable entirely and try to optically trigger the strobe, the strobe fires but I can't see its effect in the photo. It appears to me that the strobe is firing before the shutter opens. But I can't see anywhere I could change this option on the camera.

Wheatfield, can you explain what you mean by "reverse the leads on the PC socket"? Do you mean remove the audio-jack-end thingy (that plugs into the hotshoe adapter) and switch the wired connections?

If I do that, do you suppose it will help through the hotshoe adapter?

Thanks for your help.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, flash, light, pentax k-x, photography, shoe, strobe, sync
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted - Acquired: Wein Hot Shoe to Hot Shoe Safe Sync HSHSB 990-560 excanonfd Sold Items 0 08-26-2010 10:56 AM
Hot shoe strobes and umbrellas Ed n Georgia Pentax Camera and Field Accessories 14 05-12-2010 12:22 PM
Wein Safe-Sync Hot Shoe to Hot Shoe Iowa Tom Pentax DSLR Discussion 1 09-12-2009 09:20 PM
Pentax k200 Hot shoe questions/Strobes/Wireless remote Alaynna Pentax Camera and Field Accessories 1 10-22-2008 12:50 PM
For Sale - Sold: FS: Hot Shoe Adapter & Sync Cord coqui Sold Items 4 03-21-2008 04:31 PM



All times are GMT -7. The time now is 03:10 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top