Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-16-2010, 08:16 AM   #1
Senior Member
creoleart's Avatar

Join Date: Jul 2009
Location: Layton, UT
Posts: 101
Trouble playing images

I am currently using a K20D and also have a K10D and I have been having trouble playing images lately. When I push the play button to view the images, it just gets stuck there while trying to load. So when it is not loading the image, I would turn off the camera, then the number of remaining images to shoot will appear on the top and the orange light goes on on the back. I have to wait a few minutes for that light to go off and for everything to reset before I can take any pictures. THis has happened a lot with both cameras now. Has any of you have the same issues with their camera? What seems to be causing this problem? Any feedback on this would be greatly appreciated. I am getting VERY frustrated with this.
THANK YOU!

12-16-2010, 08:35 AM   #2
Veteran Member
Manel Brand's Avatar

Join Date: Sep 2008
Location: Porto
Photos: Gallery | Albums
Posts: 854
QuoteOriginally posted by creoleart Quote
I am currently using a K20D and also have a K10D and I have been having trouble playing images lately. THis has happened a lot with both cameras now.
Could be a problem with the SD card. The issue happens with different cards?
12-16-2010, 08:40 AM   #3
Veteran Member
jolepp's Avatar

Join Date: Oct 2010
Location: Finland
Photos: Albums
Posts: 3,196
With some luck it is a problem with the card (and not the camera). Trying other cards should tell, also if the trouble moves to the other body with the card it would seem that a new card is what you need.
12-16-2010, 08:59 AM   #4
Senior Member
creoleart's Avatar

Join Date: Jul 2009
Location: Layton, UT
Posts: 101
Original Poster
I did use the same card on both cameras. I will try different ones and see. I really hope it is not the camera. Thanks!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, images, light, photography, trouble
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-7 iso 3200 images: No NR, yet the faces look plastic. (11 images) pcarfan Pentax DSLR Discussion 43 08-31-2010 08:13 AM
So am I in trouble Eastern Shore Charlie Post Your Photos! 8 10-24-2008 08:46 AM
A variety of images with FA* 200/4 Macro (no bugs) - VLF competition images Marc Langille Post Your Photos! 28 08-22-2008 07:28 PM
Playing with Fire (6 images) hamidlmt Post Your Photos! 12 08-18-2007 08:16 PM
High ISO concert images with Tam 28-300 (Images) jsundin Post Your Photos! 2 07-05-2007 08:19 AM



All times are GMT -7. The time now is 07:10 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top