Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-30-2007, 11:34 AM   #1
New Member




Join Date: Sep 2007
Location: Austin, TX
Posts: 1
HELP! *istDL power-up problem :(

I bought my *ist DL brand new last October. It worked great with no problems, until one day when I turned it on, the battery meter flashed empty and the camera would not turn on. I tried lithium, CR-V3, and alkaline batteries, and even used a volt meter to make sure the batteries were good. All batteries were in perfect condition, so I know it's something with the camera.

My friend with the same camera suggested taking the batteries out and leaving the camera switch in the "On" position for a little while to make sure the power was completely drained out (?). I left it like this for a weekend, and when I put batteries back in, the same problem happened--a flashing empty battery meter. Of course, when there are no batteries in the camera, nothing happens at all, so the camera is at least recognizing that the batteries are there, it just won't allow any functioning to happen.

I don't know what to do; there is nothing in the trouble-shooting guide about this, and my warranty is up in just a few weeks. Has anyone had this problem before and could either give me suggestions or redirect me to a previous forum thread? It would be much appreciated! Thanks so much!

09-30-2007, 11:54 AM   #2
Veteran Member




Join Date: Jun 2007
Location: California
Posts: 426
Send it in for warranty before your warranty runs out. That's my recommendation.
11-09-2007, 08:59 AM   #3
New Member




Join Date: Jan 2007
Location: Florida
Photos: Gallery
Posts: 10
QuoteOriginally posted by kashmirton Quote
I bought my *ist DL brand new last October. It worked great with no problems, until one day when I turned it on, the battery meter flashed empty and the camera would not turn on. I tried lithium, CR-V3, and alkaline batteries, and even used a volt meter to make sure the batteries were good. All batteries were in perfect condition, so I know it's something with the camera.

My friend with the same camera suggested taking the batteries out and leaving the camera switch in the "On" position for a little while to make sure the power was completely drained out (?). I left it like this for a weekend, and when I put batteries back in, the same problem happened--a flashing empty battery meter. Of course, when there are no batteries in the camera, nothing happens at all, so the camera is at least recognizing that the batteries are there, it just won't allow any functioning to happen.

I don't know what to do; there is nothing in the trouble-shooting guide about this, and my warranty is up in just a few weeks. Has anyone had this problem before and could either give me suggestions or redirect me to a previous forum thread? It would be much appreciated! Thanks so much!
Our ist*DL is doing the exact same thing this week. Worse, our warranty is expired. I contacted Pentax and they suggest sending it to them for repair - which will likely take at least a month and cost us God only knows how much out of pocket to repair an "old" camera. If we could afford to just buy a newer model I would, but that is out of the question right now.

Did you ever find out what the problem was or how to fix it?
11-09-2007, 09:21 AM   #4
Forum Member
Jimsi777's Avatar

Join Date: Sep 2007
Location: Virginia
Posts: 75
change out your flash card

01-14-2008, 11:34 AM   #5
New Member




Join Date: Jan 2008
Location: Tennessee
Posts: 1
Hi all,

This is my first post on this forum. My ist*DL is doing the same thing. I pulled out my camera after some holiday use and found it had been left "On" so the batteries were dead. I pulled them out, put in new alkaline batteries (even the ones included with my camera as I had never used them). Every new set I drop in and switch to "on" cause the battery meter to blink with an empty battery emblem. So, it thinks all the batteries are depleted even though they are new.

I normally use the new Duracell Rechargeable batteries. they have worked great, but right now nothing is working.

I'm fearful of how much it will cost to fix and am just curious if any of you have experienced this issue and perhaps resolved it (or got it repaired and how much it set you back).

Anyone have any new info on this?

Thanks.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, camera, dslr, meter, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with built-in flash (*istDL) sasam1400 Pentax DSLR Discussion 1 07-24-2010 04:29 PM
kx power problem oconnmmj Pentax DSLR Discussion 9 06-06-2010 04:28 AM
Power cord for a TR Power Pack 2 Vern Pentax Camera and Field Accessories 4 12-06-2009 08:13 AM
Unique *istDL problem freeflyr Pentax DSLR Discussion 8 07-21-2008 07:47 AM
*ist D power off problem outsidenote Pentax DSLR Discussion 4 02-07-2008 06:30 PM



All times are GMT -7. The time now is 05:55 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top