Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-25-2010, 10:02 PM   #1
New Member




Join Date: Dec 2010
Posts: 3
Help - Pentax Kx problem

Hi

I'm the owner of a Pentax Kx and i have a weird problem where the lcd would just be stuck on a black screen, meaning no preview, no options display, and it usually comes back again after 4 or 5 shutter clicks.
Now when i go back to view the pictures, there is always one picture that says "unreadable file". i'm pretty sure that's why the preview doesn't display. it happens on any mode i'm using and saving in jpg.
i have tried different sd cards and the same results.

any ideas ?

thanks

12-26-2010, 11:36 AM   #2
Forum Member




Join Date: Dec 2010
Location: San Jose, California
Photos: Albums
Posts: 80
Well, the K-x has a mode where you look only through the viewfinder to adjust and confirm all your settings. Also, make sure your Instant Review is turned on, which is in the camera menu under tab three. If you want to toggle between those display modes (eg. Info menu, Standard, or display off,) just press the info button.
Hope that fixes your problem.
12-26-2010, 04:12 PM   #3
Veteran Member
KxBlaze's Avatar

Join Date: Feb 2010
Location: California
Photos: Gallery
Posts: 1,594
If it sometimes shows the preview and then goes completely black without changing any settings it sounds like an electrical problem. I would say send it back for warranty if it is still under coverage if not I would inquire at a camera repair store.
12-27-2010, 07:45 AM   #4
New Member




Join Date: Dec 2010
Posts: 3
Original Poster
I got it on ebay so no warranty. and i don't know if the seller knew about the problem or not. it seems like its unable for some reason to save the picture.
so when i go to review the pictures, there is always one that says "unable to read file". the file is also unable to be read when I put the sd card on the computer.
anyway, I will play with it for a while, if it stays the same, i'll get back to a Canon.

thanks,

12-27-2010, 08:17 AM   #5
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,109
QuoteOriginally posted by armrob Quote
............if it stays the same, i'll get back to a Canon.

thanks,
Yep, that makes sense. I know if I bought something used, off of ebay, that was defective I would most certainly see that as a reason to condemn an entire product line/brand.
12-27-2010, 11:40 AM   #6
Senior Member
dragra's Avatar

Join Date: Dec 2010
Location: Ljubljana
Photos: Albums
Posts: 238
QuoteOriginally posted by armrob Quote
I got it on ebay so no warranty. and i don't know if the seller knew about the problem or not. it seems like its unable for some reason to save the picture.
so when i go to review the pictures, there is always one that says "unable to read file". the file is also unable to be read when I put the sd card on the computer.
anyway, I will play with it for a while, if it stays the same, i'll get back to a Canon.

thanks,
Sounds to me as an read/write problem.

What kind of SD-card (brand/model) did you use?

Did you format the card before use in the camera?

Are you sure your memory card is not on "locked" position?

By the way, the same problem can happen to an used Canon, Nikon or whatever, so changing brands will not bring you much. Try to figure out and isolate the problem.

cheers,
d
12-29-2010, 08:51 AM   #7
Junior Member




Join Date: Jan 2010
Location: Laoag City
Photos: Gallery
Posts: 26
What lens did you have on? Can you record a movie?

I don't remember clearly, but, I think I had a similar problem some time back while using a Pentax-M 200mm. The mirror would get stuck in the "up" position. I think it was due to a slightly bent aperture... switch(?) in the lens. So, I straightened it out, tried it in another K-x camera, then it works again!
12-29-2010, 10:34 AM   #8
Senior Member
kari's Avatar

Join Date: Feb 2010
Photos: Albums
Posts: 149
Try a different SD card. I had a similar problem and it turned out to be a bad card.

12-30-2010, 06:32 AM   #9
New Member




Join Date: Dec 2010
Posts: 3
Original Poster
QuoteOriginally posted by kari Quote
Try a different SD card. I had a similar problem and it turned out to be a bad card.
I've tried different cards. I'm using a new one and had it formatted by the camera.
It's been a few days and I've not seen the problem yet.
So I really hope it was the card.
Thanks to all for the ideas .
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, display, dslr, kx, pentax, pentax kx, photography, preview
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Card read problem K20d. Have you had this problem? rsi1986 Pentax DSLR Discussion 8 12-27-2008 05:25 AM
Pentax 16-50 mm da* problem h0rnd0g Pentax SLR Lens Discussion 5 09-11-2008 08:06 AM
Pentax 67 problem RaySmith Pentax Medium Format 1 05-19-2008 11:02 AM
Problem, pentax 1.4x-s roy Pentax SLR Lens Discussion 11 03-03-2007 07:20 PM



All times are GMT -7. The time now is 04:49 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top