Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-07-2011, 02:13 PM   #1
Forum Member




Join Date: Feb 2009
Location: Washington - the State
Posts: 97
Need K10D Firmware Vers 1.30

Can someone email me Vers. 1.30 of the K10D Firmware? I can't find it online, and I have 1.31, but need to address some focus issues and can't get to debug with 1.31.

Email is in my profile.

Thanks

01-07-2011, 05:31 PM   #2
Veteran Member
pop4's Avatar

Join Date: Aug 2007
Location: YMML
Photos: Gallery
Posts: 1,877
Here you go, uploaded just for you: http://rapidshare.com/files/441376009/k10e130w.exe
01-07-2011, 05:33 PM   #3
Forum Member




Join Date: Feb 2009
Location: Washington - the State
Posts: 97
Original Poster
Thanks! However...I tried the link and it is asking me if I am sure I want to upload the file. No option for download.
01-07-2011, 06:07 PM   #4
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,795
click on the slow download link on the right. Wait 30 seconds then it gives you the link.

01-07-2011, 08:09 PM   #5
Forum Member




Join Date: Feb 2009
Location: Washington - the State
Posts: 97
Original Poster
Thanks! I thought those were links to buy some software.
01-07-2011, 10:51 PM   #6
Forum Member




Join Date: Feb 2009
Location: Washington - the State
Posts: 97
Original Poster
OK - I extracted the file and edited the header, but the camera gives an error - "Update File is Damaged".

Anyone else have a different copy?
01-08-2011, 04:38 AM   #7
Veteran Member
pop4's Avatar

Join Date: Aug 2007
Location: YMML
Photos: Gallery
Posts: 1,877
QuoteOriginally posted by 5shot Quote
OK - I extracted the file and edited the header, but the camera gives an error - "Update File is Damaged".

Anyone else have a different copy?
You've most likely edited the header incorrectly, which is probably why it gave the "Update File is Damaged" error. If I'm reading your posts correctly, you want to get into debug mode on your K10D, is that correct? If so, I have another firmware file that is a hacked 1.10 firmware that can get you into debug mode. However, I would strongly suggest another method, which is to get into the debug mode using a MODSET file; using this method, I can get enable the debug mode and hence extra AF adjustment of my K10D, which is currently running 1.31 firmware. The instructions for using a MODSET file should be easily found with a search of the forums.

Last edited by pop4; 01-08-2011 at 04:44 AM.
01-08-2011, 05:25 AM   #8
Pentaxian




Join Date: Oct 2007
Location: France
Photos: Albums
Posts: 804
Is is still available on the Pentax France official support site here :
TÚlÚchargement - PENTAX Europe Imaging Systems

01-08-2011, 05:54 AM   #9
Veteran Member
Ivan Glisin's Avatar

Join Date: Nov 2006
Location: Belgrade/Toronto
Posts: 656
QuoteOriginally posted by 5shot Quote
Can someone email me Vers. 1.30 of the K10D Firmware? I can't find it online, and I have 1.31, but need to address some focus issues and can't get to debug with 1.31.
No need for 1.30. Do the following with 1.31:

In the root directory of your memory card create or copy a text file named

MODSET.TXT

with only one line in it:

[OPEN_DEBUG_MENU]

After inserting card back to the camera, to enable debug mode do the following:

1. Switch camera off.
2. Open card door and leave it open.
3. Switch camera on -- debug menu shows up.
4. Close card door.
5. Left/right to enable debug mode.
6. Press OK to confirm.
7. Go to Set-Up menu, go to the end and Set-up will change to TEST MODE menu, AF TEST option is there with Focus Corr inside.

To disable debug mode:

1. Switch camera off.
2. Open card door and leave it open.
3. Switch camera on -- debug menu shows up.
4. Close card door.
5. Left/right to disable debug mode.
6. Press OK.

Note: you can permanently leave MODSET.TXT file on your card.
01-08-2011, 09:54 AM   #10
Forum Member




Join Date: Feb 2009
Location: Washington - the State
Posts: 97
Original Poster
Tried it - doesn't work. The LCD flickers and then goes dead. I was wondering if it worked if you had 1.30 prior and then upgraded to 1.31, but doesn't work if you never went into debug prior to upgrading?
01-08-2011, 09:59 AM   #11
Forum Member




Join Date: Feb 2009
Location: Washington - the State
Posts: 97
Original Poster
QuoteOriginally posted by pop4 Quote
You've most likely edited the header incorrectly, which is probably why it gave the "Update File is Damaged" error. If I'm reading your posts correctly, you want to get into debug mode on your K10D, is that correct? If so, I have another firmware file that is a hacked 1.10 firmware that can get you into debug mode. However, I would strongly suggest another method, which is to get into the debug mode using a MODSET file; using this method, I can get enable the debug mode and hence extra AF adjustment of my K10D, which is currently running 1.31 firmware. The instructions for using a MODSET file should be easily found with a search of the forums.
I would suggest that that is most likely the cause...as I know nothing about it, but was able to change the header to read version 1.31. As for the modset file - see above.
01-08-2011, 10:07 AM   #12
Forum Member




Join Date: Feb 2009
Location: Washington - the State
Posts: 97
Original Poster
NEVERMIND...

I downloaded the text file - it was one click, so I figured why not. Only issue was that the text string was [OPEN_DEBUG_MODE] and I didn't notice. It works just fine.

Sorry for the hassle guys.
07-14-2011, 02:35 AM   #13
Senior Member




Join Date: Oct 2007
Location: London
Posts: 266
can't get this to work!

anyone help me on this. have named text file modtext.txt, modtext without the txt etc. in notepad with [OPEN_DEBUG_MODE] alone and with [OPEN_DEBUG_MODE] with hitting "enter" afterwards but all that happens when I turn the camera on with the door open and card inserted is a bit of flickering.
could it have to do with running windows 2000?
thanks in advance!!
07-17-2011, 07:14 PM   #14
Veteran Member




Join Date: Oct 2010
Location: Baltimore
Posts: 2,542
QuoteOriginally posted by davidxgreen Quote
anyone help me on this. have named text file modtext.txt, modtext without the txt etc. in notepad with [OPEN_DEBUG_MODE] alone and with [OPEN_DEBUG_MODE] with hitting "enter" afterwards but all that happens when I turn the camera on with the door open and card inserted is a bit of flickering.
could it have to do with running windows 2000?
thanks in advance!!
That's all I get also, but after carefully reading this thread, I realized it could be [OPEN_DEBUG_MENU] + read the instructions above carefully. I haven't tried it again, but will in a day or so... let me know how you make out.
07-17-2011, 08:36 PM   #15
Senior Member




Join Date: Oct 2007
Location: London
Posts: 266
Couldn't get this to work but did manage to use the russian program mentioned earlier in this posting. It wasn't working either but I found the answer buried in a post somewhere - the shortcut for the russian program is no good. When I execute the program directly from its folder in "programs" it prompts me to connect the camera to the computer. Then it works as described. hth
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, email, firmware, k10d, photography, vers
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D Firmware pactrain Pentax DSLR Discussion 19 03-28-2010 07:23 PM
Firmware K10d ruemiser Pentax DSLR Discussion 6 02-24-2008 05:16 AM
K10d firmware at 1.00 Takman Pentax DSLR Discussion 9 10-26-2007 03:34 PM
k10d firmware 1.2 button Pentax DSLR Discussion 43 04-19-2007 06:14 PM
Value of the New K10D Firmware Sailor Pentax DSLR Discussion 4 01-26-2007 04:08 PM



All times are GMT -7. The time now is 03:17 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top