Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-23-2011, 10:13 AM   #1
Senior Member




Join Date: Nov 2009
Photos: Gallery
Posts: 165
K20D optical stabilization not working

Hi,
before, when i pluggd any manual lens and turned the camera on, it asked me for a focal lencght to be ready for optidcal stabilization, now it never appear... whats wrong???

01-23-2011, 10:24 AM   #2
Loyal Site Supporter
pacerr's Avatar

Join Date: Jan 2008
Location: Henry, TN
Photos: Gallery | Albums
Posts: 2,884
Is SR switched ON? It won't ask if it's not.

H2
01-23-2011, 10:25 AM   #3
Veteran Member
RioRico's Avatar

Join Date: Jun 2008
Location: Limbo, California
Posts: 11,264
Is the SR switch (underneath the 4-way controller button) set to ON?
01-23-2011, 02:15 PM   #4
Senior Member




Join Date: Nov 2009
Photos: Gallery
Posts: 165
Original Poster
sure it is set to on

01-23-2011, 07:00 PM   #5
Veteran Member
kkoether's Avatar

Join Date: Jul 2008
Location: Huber Heights, OH, USA
Photos: Gallery | Albums
Posts: 573
Try toggling it off then on. See if that helps.
01-24-2011, 12:09 PM   #6
Senior Member




Join Date: Nov 2009
Photos: Gallery
Posts: 165
Original Poster
yes, did that many times... nada!!!
01-24-2011, 12:24 PM   #7
Loyal Site Supporter
eddie1960's Avatar

Join Date: Aug 2010
Location: Toronto
Photos: Gallery | Albums
Posts: 12,264
make sure it's not disabled in the menus as well
If all this fails to fix it then the switch needs repair likely
01-24-2011, 12:25 PM   #8
New Member




Join Date: Nov 2010
Posts: 22
Are you sure it's not working, or do you think it's not working because it doesn't ask for a focal length?
In case of the last, it might be working afterall, doesn't the k20d save settings for a given number of non af lenses?

01-24-2011, 02:33 PM   #9
Senior Member




Join Date: Nov 2009
Photos: Gallery
Posts: 165
Original Poster
is not working, because if i press the info button, i can see the hand crossed with a white line....
01-24-2011, 04:15 PM   #10
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,108
QuoteOriginally posted by eddie1960 Quote
make sure it's not disabled in the menus as well
If all this fails to fix it then the switch needs repair likely
I just think this bears repeating.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, photography, stabilization
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20D Shutter Not Working!!! Murdoughnut Pentax DSLR Discussion 8 09-06-2010 11:40 PM
K20D AF not working properly dgaies Pentax DSLR Discussion 18 03-09-2010 01:15 AM
K20D - Not working Rusty27 Pentax DSLR Discussion 10 12-02-2009 06:14 AM
Sony and Pentax to get optical stabilization, courtesy of Sigma? ftpaddict Pentax SLR Lens Discussion 12 03-09-2009 02:21 AM
In-body stabilization + lens stabilization ntx Troubleshooting and Beginner Help 14 02-24-2009 05:24 PM



All times are GMT -7. The time now is 12:48 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top