Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-08-2011, 09:03 PM   #1
New Member
au22ru's Avatar

Join Date: Apr 2010
Location: Melbourne
Posts: 13
Double mirror flip problem K-r with M42 lens

Hi.

Discovered a problem with K-r, which doesn't look bad, but annoying.

Conditions:
- M42 manual focus lens with simple adapter
- single frame shooting (continuous with single shot as well)
- aperture priority (didn't try other modes)
- NOT in a Live View Mode

Result:
1. If I shoot slowly, with 1 sec or more interval between photos it's all OK.
2. If I press (and release) the button faster, few times a second:
- after 2-3 shots camera makes mirror flip sound twice before every picture, and
- sometimes single mirror flip sound few seconds after the last shot, and
- couple of times the camera hangs with open mirror but closed shutter and
doesn't react to anything, until the battery removal stops this SR noise agony

With this double sound camera produces single shot only with normal exposure.
The problem developed in a past few weeks. It may be the result of some
changes in camera settings, i tried reset it, but with no luck.

Any ideas?

02-09-2011, 02:18 AM   #2
Veteran Member
blende8's Avatar

Join Date: Feb 2007
Location: Bremen, Germany
Photos: Albums
Posts: 1,484
What M42 lens are you using?
It may be a contact problem.
If the contacts are not shortened correctly, the camera may behave weirdly.
Just a guess.
02-09-2011, 06:11 AM   #3
New Member
au22ru's Avatar

Join Date: Apr 2010
Location: Melbourne
Posts: 13
Original Poster
QuoteOriginally posted by blende8 Quote
What M42 lens are you using? Just a guess.
Na-h, don't think so, that combo is a full metal jacket, so all the contacts are grounded.

Soviet one:


Chinese one:

02-09-2011, 06:40 AM   #4
Veteran Member
blende8's Avatar

Join Date: Feb 2007
Location: Bremen, Germany
Photos: Albums
Posts: 1,484
Hmm, ok ...
And this does not happen with the kit lens?
What happens if you shoot without any lens and adapter?

02-09-2011, 02:19 PM   #5
Ira
Inactive Account




Join Date: Mar 2009
Location: Coral Springs, FL
Photos: Gallery | Albums
Posts: 5,218
This is a known issue, but damn if I can remember the reason.
02-09-2011, 11:16 PM   #6
New Member
au22ru's Avatar

Join Date: Apr 2010
Location: Melbourne
Posts: 13
Original Poster
QuoteOriginally posted by blende8 Quote
Hmm, ok ...
And this does not happen with the kit lens?
What happens if you shoot without any lens and adapter?
It's OK with any non manual lens.
And it shoots normally with no lens at all.

As soon as I have that ring-adapter the problem starts.
I had no problem with adapters on K-x...

Last edited by au22ru; 02-10-2011 at 07:06 AM.
02-09-2011, 11:20 PM   #7
New Member
au22ru's Avatar

Join Date: Apr 2010
Location: Melbourne
Posts: 13
Original Poster
QuoteOriginally posted by Ira Quote
This is a known issue, but damn if I can remember the reason.
Mate, it's dangerous to give someone a piece of hope :)
Do you remember if it's fixable in settings or is it
something I need to take back to Pentax?
02-10-2011, 10:58 AM   #8
Veteran Member




Join Date: Sep 2007
Location: USA
Posts: 1,812
QuoteOriginally posted by Ira Quote
This is a known issue, but damn if I can remember the reason.
QuoteOriginally posted by au22ru Quote
Mate, it's dangerous to give someone a piece of hope
Wouldn't want that -

could this be the thread?
K-r with manual lenses, first impressions
started by ovim
and he points out in post #9
that the K-x seems to act in a similar way:
Green Button Stop-Down Metering Acting Differently

02-11-2011, 02:45 AM   #9
New Member
au22ru's Avatar

Join Date: Apr 2010
Location: Melbourne
Posts: 13
Original Poster
Thanx mate, I'll check it out.
02-11-2011, 02:29 PM   #10
Veteran Member
lavascript's Avatar

Join Date: Jul 2009
Location: Baton Rouge
Posts: 390
I'm having what sounds like the same problem with a Vivitar 70-210:

https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/130899-old-viv...-like-k-r.html
https://www.pentaxforums.com/forums/pentax-k-r-forum/130643-old-vivitar-70-21...t-working.html
02-12-2011, 03:15 AM   #11
New Member
au22ru's Avatar

Join Date: Apr 2010
Location: Melbourne
Posts: 13
Original Poster
Update and finale.

Yes, the contacts. What happened, yesterday I finally decided
to cut that wide flat part of adapter (post #3 here, bottom).
That 1mm thick flange changes focal length and I cannot focus to infinity.

So I took it off (belt grinder) and voilą, infinity is back.
And the first few shots - no double mirror flip!
Now camera contacts touching not the chromed adapter, but the black
finish of the lens (looks like a blued gun metal).

Did I get any circuit or did I loose it? Who knows. It works fine now.
07-22-2011, 04:17 AM   #12
Veteran Member
theperception2008's Avatar

Join Date: Aug 2009
Location: Łódź, Poland and Riverside, California, U.S.A
Photos: Gallery | Albums
Posts: 488
my camera did that too but only on my 16-45. Then I carefully examined the lens to find out that the aperture lever was bent in about 1-2 mm in comparison to my other lenses, so I bent it back out just a little bit and the problem stopped :-)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-r, lens, m42, mirror, photography, result, shot, sound, times
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Vivitar 500mm Multi-Coated Mirror Lens, M42 Screwmount wallyb Sold Items 9 08-22-2009 11:25 AM
Mirror lens conversion problem gumpa Pentax DSLR Discussion 11 03-10-2009 04:44 AM
For Sale - Sold: Vivitar 500mm Mirror m42 Lens with Filter Set, Worldwide Ship wallyb Sold Items 0 12-29-2008 11:17 AM
Revuenon 8/500mm M42 mirror lens Spex Pentax SLR Lens Discussion 2 08-31-2008 11:55 AM
Russian 1100mm f10.5 M42 mirror lens Matjazz Pentax SLR Lens Discussion 14 10-08-2006 08:44 AM



All times are GMT -7. The time now is 02:49 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top