Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-25-2011, 07:45 PM   #1
Site Supporter
Chaos_Realm's Avatar

Join Date: Feb 2011
Location: Melbourne, Australia
Photos: Gallery | Albums
Posts: 1,248
K-7 Battery Life Issue

Hi guys,
I've had a quick look and couldn't find anything on this issue.

When shooting with my K-7 I will have an issue with it randomly showing "Battery Depleted" and shutting off. I have tested this with 2 OEM Batteries, and it tends to happen when I have done some shooting with Live View. Yes I know that this will deplete battery faster but, the battery indicator will be still showing full battery, and sure enough when i turn it back on it will work perfectly fine! (live View included)
I don't think its a firmware problem but non the less I have to wait to update firmware, as I don't have my cable where I am for the next week or two. (current version is 1.10)

03-25-2011, 08:21 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,944
If you're using a grip, check to make sure the full battery is selected. The only other explanation would be that the voltage on your battery was low at the time.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-25-2011, 08:32 PM   #3
Site Supporter
Chaos_Realm's Avatar

Join Date: Feb 2011
Location: Melbourne, Australia
Photos: Gallery | Albums
Posts: 1,248
Original Poster
Hi Adam, Thanks for the quick response!

I don't have a battery grip (Yet!).

Would the low voltage be a faulty batteries. I know 2 faulty batteries is unlikely but is still possible.
I know its not cold environment that is causing voltage drop as the temps (although cooler than normal) are not low comparatively.
03-25-2011, 08:32 PM   #4
Site Supporter
BigDave's Avatar

Join Date: Sep 2010
Location: Hudson Valley, NY
Photos: Gallery | Albums
Posts: 1,433
I have seen something like this with my K7, and I believe it is when I am using live view and LV is really pulling down the battery. When I switch LV off, the battery level does go back up, but I know I've drained it a fair amount. Early on I got two B/U batteries as I know Murphy's law dictates the battery will die just when that great shot is about to enter........

03-25-2011, 08:43 PM   #5
Site Supporter
Chaos_Realm's Avatar

Join Date: Feb 2011
Location: Melbourne, Australia
Photos: Gallery | Albums
Posts: 1,248
Original Poster
QuoteOriginally posted by BigDave Quote
I believe it is when I am using live view and LV is really pulling down the battery. When I switch LV off, the battery level does go back up, but I know I've drained it a fair amount.
I suppose the battery after heavy loading might have a temporary low in Voltage, Its a real pain as I have been using the lv to magnify to 6X-8X to get the focus smack on (with f1.8 on the FA 77 Ltd) I switch of lv and go to shoot or compose and the battery dies! Its a PITA!.
Would having a battery grip help to provide a more constant voltage supply and "fix" this issue?
03-25-2011, 09:50 PM   #6
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
Live view does suck the power down considerably. The grip can help with that. I don't know exactly what is going on with your particular batteries (age?) however.

03-26-2011, 12:00 AM   #7
Site Supporter
Chaos_Realm's Avatar

Join Date: Feb 2011
Location: Melbourne, Australia
Photos: Gallery | Albums
Posts: 1,248
Original Poster
QuoteOriginally posted by JeffJS Quote
(age?)
Batteries are effectively still new. Bought one 27th Dec 2010 and the other mid Jan 2011.

I am going to run a firmware update ( I just realised I don't need to have the usb cable to update ) see what that does for it. Not sure if there can be partial errors in firmware V1.10 but I hope that is all it turns out to be!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, dslr, firmware, issue, k-7, photography, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
AA battery life jslifoaw Pentax DSLR Discussion 54 06-05-2011 05:26 PM
Battery life for K-x wally1 Troubleshooting and Beginner Help 21 01-25-2011 07:13 AM
K-x Battery Issue gkamieneski Pentax DSLR Discussion 6 12-17-2010 02:51 PM
Battery Life soppy Pentax K-5 14 12-06-2010 02:02 PM
Battery issue with K-x switters Pentax DSLR Discussion 15 02-26-2010 09:06 AM



All times are GMT -7. The time now is 07:20 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top