Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-03-2007, 07:37 AM   #1
Inactive Account




Join Date: Mar 2007
Location: Hertfordshire UK
Posts: 28
AF360FGZ and K10D problem

I am having a problem with this combination recently. Not having used the flashgun for some time I yesterday got it out because I wanted to use it at an event that I wanted to photograph. However I encountered a rather funny problem when I came to use it. The ready light lit just after switch on but when I pressed the the shutter button to focus, the light went out and the flash did not fire and the shot was way underexposed. Occasionally it did fire. The flash will fire OK off camera when the 'ready' light is pressed and will recharge Ok after a few seconds. The flash is set to P-TTL and Auto Flash and mounted on the camera. Am I missing something or is the Flashgun faulty or the Camera.

11-03-2007, 02:42 PM   #2
Veteran Member
clawhammer's Avatar

Join Date: Sep 2007
Location: Logan, Utah
Photos: Gallery
Posts: 976
have you tried cleaning the contacts on the bottom of the flash/top of the camera? It sounds like there is a connection problem between the camera and flash.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, fire, flash, flashgun, light, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10d + af360fgz ndy4eva Pentax DSLR Discussion 4 08-26-2009 09:01 PM
Problem with AF360FGZ and K100D on P-TTL Yarf Flashes, Lighting, and Studio 3 09-02-2008 07:31 PM
K100D and AF360fgz problem zorobabel Flashes, Lighting, and Studio 13 05-02-2008 03:12 PM
Problem with AF360FGZ on K20D foots Pentax DSLR Discussion 2 04-21-2008 06:59 PM
AF360FGZ Problem JohnV3 Pentax DSLR Discussion 8 01-11-2007 07:31 PM



All times are GMT -7. The time now is 11:59 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top