Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-21-2011, 12:07 AM   #1
Pentaxian
ducdao's Avatar

Join Date: Dec 2009
Location: Montreal/Vermont
Posts: 2,160
K200D not able to connect to PC through USB cable

I just got an used K200D and it is set to USB = PC under the menu setup and I still can't make the connection to transfer the images to my PC through the USB port.

The previous owner never transfered images through USB port so he doesn't know whether it worked or not. The camera has only 8,000 actuations on it and it looks like new.

I use the same cable on my K10D and PC and it works. The cable is the genuine one from my K10D as I no longer have the one that came with the K200D.

I'm sure it's not the memory card since when I connect it through a card reader it works fine and I have no problem saving/deleting images from it.

So it leaves me to 2 possibilities.

1. The usb cable for K200D and K10D are two different types. Can someone confirm or negate?

2. The micro-usb jack on my K200D is somehow broken. Anyone had that issue before?

I personally prefer transferring my images through the USB cable but in the worst case I still can use the alternative way which is to transfer it through a card reader...

05-21-2011, 12:16 AM   #2
Veteran Member
wlachan's Avatar

Join Date: Sep 2006
Location: Canada
Photos: Albums
Posts: 2,626
The USB port is known to be weak on Pentax DSLRs. I don't know why yours didn't connect though. Either it's physically broken, or it needs the Pentax software to be loaded. I have never connected mine as I use a card reader.
05-21-2011, 12:41 AM   #3
New Member




Join Date: Jan 2008
Location: Brugelette, Belgium
Posts: 20
Have you tried : Menu -> Set-up -> USB Connection -> PC ?
05-21-2011, 12:44 AM   #4
Pentaxian
ducdao's Avatar

Join Date: Dec 2009
Location: Montreal/Vermont
Posts: 2,160
Original Poster
QuoteOriginally posted by Jieffe Quote
Have you tried : Menu -> Set-up -> USB Connection -> PC ?
Yes, I did. This is my 4th Pentax DSLR body (don't ask me why ). I currently have the K100D, K10D, K20D and K200D. Only the K200D is giving this problem.

05-21-2011, 12:46 AM   #5
Pentaxian
ducdao's Avatar

Join Date: Dec 2009
Location: Montreal/Vermont
Posts: 2,160
Original Poster
QuoteOriginally posted by wlachan Quote
The USB port is known to be weak on Pentax DSLRs. I don't know why yours didn't connect though. Either it's physically broken, or it needs the Pentax software to be loaded. I have never connected mine as I use a card reader.
I currently use LR3 and Aperture 3 for MAC and none of them can see it when I connect it through the USB part. Card reader works just fine.

I will download the Pentax software and see if it works or not but my guess is the USB port on my K200D is broken.
05-21-2011, 07:17 AM   #6
Site Supporter
joebob's Avatar

Join Date: Dec 2008
Location: Massachusetts
Photos: Gallery
Posts: 163
It's unlikely a compatibility issue with the cable. I have a K200D and use the cable that came with my K110D to transfer pictures. What operating system are you using?
05-21-2011, 07:22 AM   #7
Site Supporter




Join Date: Jan 2010
Location: Michigan
Photos: Gallery
Posts: 2,073
Hi, duc,
I broke a usb connector (in the camera) by accidentally pulling it.
Damage is not visible.
Now I have a heavy key tag on the camera end of the cable as a reminder when i pick up the camera
05-21-2011, 10:05 AM   #8
Pentaxian
ducdao's Avatar

Join Date: Dec 2009
Location: Montreal/Vermont
Posts: 2,160
Original Poster
QuoteOriginally posted by joebob Quote
It's unlikely a compatibility issue with the cable. I have a K200D and use the cable that came with my K110D to transfer pictures. What operating system are you using?
I'm on MacOSX 10.6.7 (latest). I have 2 macbook pro and they both don't recognize my K200D when plugged through the USB port. I guess my USB port on the K200D is broken. I see no visible dammage though.

05-21-2011, 11:42 AM   #9
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
QuoteOriginally posted by wlachan Quote
The USB port is known to be weak on Pentax DSLRs. I don't know why yours didn't connect though. Either it's physically broken, or it needs the Pentax software to be loaded. I have never connected mine as I use a card reader.
+1 from me.
05-21-2011, 12:00 PM   #10
Veteran Member




Join Date: Oct 2010
Location: Baltimore
Posts: 2,542
QuoteOriginally posted by ducdao Quote
I'm on MacOSX 10.6.7 (latest). I have 2 macbook pro and they both don't recognize my K200D when plugged through the USB port. I guess my USB port on the K200D is broken. I see no visible dammage though.
The last thing to try is to check the Firmware and see if there are updates that address the issue.
05-21-2011, 01:11 PM   #11
Site Supporter
joebob's Avatar

Join Date: Dec 2008
Location: Massachusetts
Photos: Gallery
Posts: 163
QuoteOriginally posted by ducdao Quote
I'm on MacOSX 10.6.7 (latest). I have 2 macbook pro and they both don't recognize my K200D when plugged through the USB port. I guess my USB port on the K200D is broken. I see no visible dammage though.
Can't help you there. But if you know someone who has a PC running windows, you could try that. Once plugged in, windows should see the camera as soon as you turn it on.
05-21-2011, 03:25 PM   #12
Senior Member




Join Date: Mar 2009
Location: Massachusetts
Photos: Gallery
Posts: 186
On the mac side, I had to install the pentax SW package to get the drivers. On the PC, it worked without drivers.
05-21-2011, 06:27 PM   #13
Pentaxian
ducdao's Avatar

Join Date: Dec 2009
Location: Montreal/Vermont
Posts: 2,160
Original Poster
QuoteOriginally posted by joebob Quote
Can't help you there. But if you know someone who has a PC running windows, you could try that. Once plugged in, windows should see the camera as soon as you turn it on.
QuoteOriginally posted by markdesmarais Quote
On the mac side, I had to install the pentax SW package to get the drivers. On the PC, it worked without drivers.
Thanks, guy. I'll try to find a PC to test and report back. However, I really don't think it's the problem since all my other Pentax DSLR bodies work on my Macs.
05-21-2011, 08:08 PM   #14
Pentaxian
ducdao's Avatar

Join Date: Dec 2009
Location: Montreal/Vermont
Posts: 2,160
Original Poster
QuoteOriginally posted by theunartist Quote
The last thing to try is to check the Firmware and see if there are updates that address the issue.
Hi Rick - my K200D has the the firmware 1.01 installed which is the latest one.
05-21-2011, 08:28 PM   #15
Pentaxian
ducdao's Avatar

Join Date: Dec 2009
Location: Montreal/Vermont
Posts: 2,160
Original Poster
OK, guys. This is getting really intriguing and interesting. I just took my PC laptop from work, it runs on WindowsXP with latest SP and patches.

When I plug my K200D to the laptop through the USB, the laptop sees the device, set it as a "Mass storage device" and allocates it as drive E which is fine. Now the funny part is:

1. The top LCD of the K200D doesn't show "PC" sign which it should when connected with a PC. It simply shows the typical information such as shutter speed, ISO, etc....

2. Now on the laptop, I open the Windows Explorer, it sees the Drive E but when I click on it, Windows pops up "Please insert a disk into Drive E" I'm baffled!

This tells me that the USB port on K200D is probably working but the software on the K200D is probably not.


I'll keep playing and report back any progress.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cable, camera, card, dslr, images, k10d, k200d, pc, photography, port, transfer, usb
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
The USB Cable I-USB7, K-7, Sandisk CWyatt Pentax DSLR Discussion 6 10-27-2010 12:13 PM
K-x USB cable, is it proprietary? Muse Pentax DSLR Discussion 3 08-04-2010 08:41 PM
USB Cable gkamieneski Pentax DSLR Discussion 12 05-21-2010 02:48 PM
K200D replacement USB cable? rpriedhorsky Pentax Camera and Field Accessories 5 04-30-2009 09:00 PM
Connect K20D to USB HDD? olaab Pentax Camera and Field Accessories 6 03-15-2009 02:24 AM



All times are GMT -7. The time now is 06:54 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top