Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-26-2011, 10:28 PM   #1
Veteran Member
GordonZA's Avatar

Join Date: Jan 2010
Location: Planet Earth
Photos: Albums
Posts: 337
K10D problem?

My trusty old K10D seems to be developing an issue in very cold weather that I have never noticed before.

When the temperature drops below -2C it seems like the CCD starts to malfunction. I will take photos and there is either a completely black photo or sometimes just a mono colour like green or yellow...

I have used the camera in those kinds of temperatures for many years and never experienced this before.

Anyone else ever experienced this before?

I suspect I may well be upgrading soon...

Cheers,
Gordon

06-27-2011, 04:38 AM   #2
Pentaxian
Digitalis's Avatar

Join Date: Mar 2009
Location: Adelaide.
Posts: 8,795
Could be the LCD screen acting up, in cold temperatures it has been known to happen. I have had my K10D since 2006 and it has been doing very well for itself- it's a little worse for wear but I do not give any of my cameras special treatment.
06-27-2011, 05:10 AM   #3
Veteran Member




Join Date: Oct 2010
Location: Baltimore
Posts: 2,542
QuoteOriginally posted by GordonZA Quote
My trusty old K10D seems to be developing an issue in very cold weather that I have never noticed before.

When the temperature drops below -2C it seems like the CCD starts to malfunction. I will take photos and there is either a completely black photo or sometimes just a mono colour like green or yellow...

I have used the camera in those kinds of temperatures for many years and never experienced this before.

Anyone else ever experienced this before?

I suspect I may well be upgrading soon...

Cheers,
Gordon
I've only experienced something similar once, awhile back in the summer... turned out to be the SD Card was starting to fail, only 1 or 2 photos out of a bunch but as soon as I got another card, all was fine
06-27-2011, 01:36 PM   #4
Veteran Member
Larsenio's Avatar

Join Date: Jan 2009
Location: Andenes
Photos: Gallery
Posts: 361
My K10d had to be repaired (or tossed actually, the cost of repairing was too expensive for me to justify...) for the exact same reason as you describe

On a cold -and I mean cooooold- (around -20degrees Celsius) winter`s day, all my pictures turned out green. Thought and hoped it was the sd-card or something else, but it was in fact the mother board that went kaputt all the sudden.
Had it for three winters straight without any symptoms but I guess it can happen when you least expect it.



Off topic; the CCD-sensor in the K10D was beyond comparisation when it comes to ISO100-200 colour tones -and tack sharp images.

I hope for the best with your camera. My own experience with my upgrade to the K20D is ambivalent... I love/hate the CMOS. Produces much more refined and sharp images at mid-high ISO, but not as sharp in the lower side...
I wish there could be manufactured a Pentax with 14-18mp CCD-sensor!
:ugh:

06-27-2011, 02:02 PM   #5
Veteran Member
Northern Soul's Avatar

Join Date: Feb 2008
Location: The North of England
Photos: Albums
Posts: 491
My k10d produced an image with a strange hue once, because the battery failed as it was saving it.

Could it be that the cold is draining your battery, or preventing it from operating properly, or something? Not sure if that's plausible. How is it in more normal temperatures?
06-27-2011, 03:16 PM   #6
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
Enjoy the upgrade.


6400
06-27-2011, 09:37 PM   #7
Veteran Member
GordonZA's Avatar

Join Date: Jan 2010
Location: Planet Earth
Photos: Albums
Posts: 337
Original Poster
The camera is fine in warmer weather. When it does this, the picture is there on the SD card but there is either just a black image or a green image... The battery was fully charged and the camera behaved normally otherwise.

I suspect it is probably a dry joint somewhere on the motherboard that is contracting below a certain temperature... if I keep the camera under my jacket and warm it, then it returns to normal.

I have had excellent use from this camera so while I am sad it is reaching the end of its life, I am certainly going to enjoy the upgrade...

Thanks guys!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k10d, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D AF Problem? Relic Pentax DSLR Discussion 4 12-13-2010 05:54 PM
Problem with K10d Chris_barr Pentax DSLR Discussion 2 06-23-2010 04:13 PM
Problem with k10d W.Groves Pentax DSLR Discussion 3 05-27-2010 10:46 PM
K10D problem jiamn Pentax DSLR Discussion 13 09-20-2009 03:13 PM
K10D - Mirror problem oppositz Pentax DSLR Discussion 4 07-19-2009 01:48 PM



All times are GMT -7. The time now is 02:09 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top