Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-28-2007, 11:21 AM   #1
New Member




Join Date: Nov 2007
Location: Poca, WV
Posts: 7
K100D Super issue?

Hi,

I've just received my K100D Super (body only, lens will arrive next Monday) and also joined Pentax Forums.

I noticed that when you turn the body from one side to another it makes a sound as if something is loose inside. Is it normal?

The camera looks OK, I turned it on and it seems to be working fine.

I hope you can help me to clarify this!

Regards,
Magnus

11-28-2007, 03:47 PM   #2
Veteran Member




Join Date: Aug 2007
Photos: Gallery
Posts: 1,563
QuoteOriginally posted by hdvalente Quote
Hi,

I've just received my K100D Super (body only, lens will arrive next Monday) and also joined Pentax Forums.

I noticed that when you turn the body from one side to another it makes a sound as if something is loose inside. Is it normal?

The camera looks OK, I turned it on and it seems to be working fine.

I hope you can help me to clarify this!

Regards,
Magnus
It is the sensor that detects the position of the camera; portrait or landscape.
Works with gravity. Your camera is not broken.
Works as designed.

- Bert
11-28-2007, 04:23 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,668
Can you please stop asking DSLR-related questions in the site suggestions section? Thanks! I'll move this thread to the appropriate section in a few minutes.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-28-2007, 04:34 PM   #4
New Member




Join Date: Nov 2007
Location: Poca, WV
Posts: 7
Original Poster
QuoteOriginally posted by Mo Quote
Can you please stop asking DSLR-related questions in the site suggestions section? Thanks! I'll move this thread to the appropriate section in a few minutes.
Dear Adam,

My apologies. It was my first message right after registering.
I didn't notice it was Errors related to the forum.

And thanks for your prompt reply Bert!

Regards,
Magnus


Last edited by hdvalente; 11-28-2007 at 04:40 PM.
11-28-2007, 07:34 PM   #5
Veteran Member
mattdm's Avatar

Join Date: Feb 2007
Location: Boston, MA
Photos: Gallery
Posts: 2,964
QuoteOriginally posted by bymy141 Quote
It is the sensor that detects the position of the camera; portrait or landscape.
Works with gravity. Your camera is not broken.
Works as designed.
You have a K10D, not a K100D, right? I know, because the K100D has no such sensor.

It could, however, be the shake reduction mechanism. How loud of a sound are we talking about.
11-28-2007, 07:45 PM   #6
Forum Member




Join Date: Oct 2007
Location: Oregon
Posts: 89
If you turn Anti Shake on the rattle will go away.

Pentax unlike other manufactures doesn't lock it's Anti Shake in the off position. Therefore it will rattle around. Will not harm the camera.

RG.
11-28-2007, 08:01 PM   #7
New Member




Join Date: Nov 2007
Location: Poca, WV
Posts: 7
Original Poster
It's a K100D Super.
It has these 2 features as K10D:
1- shake reduction
2- dust removal
11-28-2007, 08:02 PM   #8
New Member




Join Date: Nov 2007
Location: Poca, WV
Posts: 7
Original Poster
QuoteOriginally posted by mattdm Quote
You have a K10D, not a K100D, right? I know, because the K100D has no such sensor.

It could, however, be the shake reduction mechanism. How loud of a sound are we talking about.
It's not loud but you can notice if you pay some attention.

11-29-2007, 02:23 AM   #9
Senior Member




Join Date: Sep 2007
Location: Lommel, Belgium
Posts: 285
I have the same on my K100D Super and like said above it's probably the Shake Reduction.

as I understand from what people told about this here before is that the sensor in the K100D Super is not fixed (just held in place by a magnetic field) so that it can move to counter some mild shakes (when shooting without a tripod for example). the same magnetic field moves the sensor lightning fast to reduce the shakes.

I guess then when the camera is off there is no electric curent to feed the magnetic field so the sensor can move around freely in the body (on in the space it's allowed to move in).

Anyways, it should be normal and harmless however you could argue that moving the sensor like this could damage it in the long run ?
11-29-2007, 03:22 AM   #10
Veteran Member
creampuff's Avatar

Join Date: May 2007
Location: Singapore
Photos: Gallery
Posts: 3,955
It is the anti-shake mechanism. There is nothing wrong with your camera and no, it will not cause any damage to the sensor.
11-29-2007, 08:52 AM   #11
New Member




Join Date: Nov 2007
Location: Poca, WV
Posts: 7
Original Poster
Thanks for your feedbacks. First time I noticed it I thought something was wrong...

Regards,
Magnus
11-29-2007, 09:04 AM   #12
Veteran Member




Join Date: Aug 2007
Photos: Gallery
Posts: 1,563
QuoteOriginally posted by mattdm Quote
You have a K10D, not a K100D, right? I know, because the K100D has no such sensor.

It could, however, be the shake reduction mechanism. How loud of a sound are we talking about.
You are right. I did assume and was wrong.
You must have both?

- Bert
11-29-2007, 09:13 AM   #13
Veteran Member
mattdm's Avatar

Join Date: Feb 2007
Location: Boston, MA
Photos: Gallery
Posts: 2,964
QuoteOriginally posted by bymy141 Quote
You are right. I did assume and was wrong.
You must have both?
I had the K100D and replaced it with the K10D. It sounds a bit silly, but I sometimes think all other factors aside, having the rotation sensor is alone worth the price difference.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, camera, dslr, k100d, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
ME super Shutter issue, help winglik Pentax Film SLR Discussion 0 03-01-2009 01:38 PM
Infinity issue with Super Takumar 50/1.4 shutterdrone Pentax SLR Lens Discussion 3 04-28-2008 04:50 PM
Issue with Pentax K100D Paulc1964au Pentax DSLR Discussion 1 08-05-2007 05:03 AM
K100D battery issue Pierrot Pentax DSLR Discussion 22 04-04-2007 10:04 AM



All times are GMT -7. The time now is 02:00 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top