Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-09-2007, 10:59 PM   #1
Forum Member




Join Date: Oct 2007
Location: Oregon
Posts: 89
K10D Spot on some images. Help Please.

I shot around 100 images today and during processing noticed a pretty large spot almost in the center of some images.
Was shooting for our Fire Dep't in temp of around 28-30F for about 2 hours using various apertures, which I know can affect how much a dust spot shows up, or maybe not at all.

I haven't had any problems prior to today. Changed lenses last week and shot event just fine, then changed back to another lens just prior to today's event.

I have tried a bulb blower. In camera dust removal about a dozen times. Camera Sensor clean feature three times, all to no avail. Also tried another lens and the spot is still there.

Anyone have any ideas ? Only had K10D for 6 months.

Thanks, Rg.

PS.

Have owned another DSLR without dust removal feature for over 3 years, changed lenses many times, never a problem with spots on images.

12-09-2007, 11:15 PM   #2
Veteran Member
-spam-'s Avatar

Join Date: Sep 2006
Location: Brisbane, Australia
Posts: 357
Can you post an example photo? Would help a lot in determining if its dust or something else.
12-10-2007, 12:05 AM   #3
Forum Member




Join Date: Oct 2007
Location: Oregon
Posts: 89
Original Poster
Spam.

Thanks.

Here you go. I took another image of approx the same scene from same place, no spot !!!!!!

You can see it near the bottom of the smoke. It also looks like it has shade circling it.

Rg.

12-10-2007, 12:17 AM   #4
Veteran Member
-spam-'s Avatar

Join Date: Sep 2006
Location: Brisbane, Australia
Posts: 357
Looks like sensor dust to me. If you have tried the sensor shake thing and blowing the sensor with a rocket blower (or something similar) in sensor clean mode, then i think you should look at getting a sensor cleaning kit to get rid of it yourself.

Alternatively, you could send it away to get it cleaned (assuming that pentax does offers that like canon)

12-10-2007, 02:01 AM   #5
Inactive Account




Join Date: Sep 2006
Location: Lancaster, PA.
Photos: Gallery
Posts: 2,041
Hi RG:
It's looking like sensor dust. If you have the K10 try the anti dust mode. If that doesn't work Use a rocket blower or something similar. If that doesn't do the trick try first with a dry pec pad on a swab and lightly go over the sensor. If your still having trouble there are some good cleaners on the market. Try one of those. If your not too keen on doing this your self then take it to any camera shop that has a good reputation for repair and ask them to clean it for you. It should take care of the problem.
12-10-2007, 10:50 AM   #6
Forum Member




Join Date: Oct 2007
Location: Oregon
Posts: 89
Original Poster
Thanks for the suggestions guys.

Rg.
12-10-2007, 11:22 AM   #7
Forum Member




Join Date: Oct 2007
Location: Oregon
Posts: 89
Original Poster
I locked the mirror up once again, held the camera under a bright lamp and gave it three good blasts with a Rocket Blower right above the sensor. You would not believe the big chunk of debris that flew out of there. Certainly big enough to see in the palm of ones hand (If I could have found it)

How on earth could something that big get in there is beyond me. I am very careful changing lenses, I never ever put a lens on without using my blower first and have not had the problem with my other over 3 year old DSLR.

I am beginning to wonder if it was floating around in the body from new.

Anyway thanks to all for the help.

Cheers, Rg.
12-11-2007, 04:01 AM   #8
Veteran Member
Mike Cash's Avatar

Join Date: Jan 2007
Location: Japan
Photos: Gallery
Posts: 6,952
It's possible that you may have blown it in there with the blower in the first place.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, dust, event, feature, images, photography, removal, shot, spot, times
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New K10D New Images cozzie22 Post Your Photos! 9 01-27-2008 10:00 AM
first images with my k10d elnero Post Your Photos! 6 01-21-2008 09:59 AM
A few K10D tourist images of Italy (9 images, about 200kb each) volosong Post Your Photos! 2 04-24-2007 04:29 AM
New K10D, bad spot on sensor?? tommy3 Pentax DSLR Discussion 4 02-21-2007 07:53 PM
K10D: True spot focus? Approx. Size? Photomy Pentax DSLR Discussion 4 02-01-2007 10:04 AM



All times are GMT -7. The time now is 11:45 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top