Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-23-2011, 07:11 AM   #1
Forum Member




Join Date: Jun 2010
Location: TX
Posts: 68
Pentax K-7 SR

Hello i had a question about Pentax k-7 Does SR (Shake Reduction) work when there is no LENS attached to the camera? On my camera i cant enable SR, is this because no Lens is attached to the camera ? Or SR should be able to enable and function even without lens attached to the camera? Thank you.

10-23-2011, 07:42 AM   #2
Forum Member




Join Date: Jun 2010
Location: TX
Posts: 68
Original Poster
ANYONE? Just want to know if SR WORKS WITHOUT LENS ON PENTAX K-7 CAMERA?
10-23-2011, 07:57 AM - 1 Like   #3
JHD
Veteran Member




Join Date: Jan 2010
Photos: Albums
Posts: 1,407
No, it won't. You need to mount a lens in order for SR to work.
10-23-2011, 09:04 AM - 1 Like   #4
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,056
Works on my K7. Remove lens, power up, turn on live-view. She makes the normal SR noises.
Also the shaky hand icon lights up in the VF when not in live-view


Last edited by Ex Finn.; 10-23-2011 at 02:06 PM.
10-23-2011, 12:40 PM   #5
Forum Member




Join Date: Jun 2010
Location: TX
Posts: 68
Original Poster
That is strange with my K-7, the SR icon is completely disabled, i cannot access it, enable it at all, i have tried, green mode, AV, User, all modes, and it seems locked, just the icon and the red line over it appear, when i use the VF, i cannot see the icon light up. Do you mind without the lens, accessing the camera menu, and going to the menu where it has the option to enable.disable SR, is yours completely blocked and cant be accessed? In my camera SR function cannot be enabled at all.
10-23-2011, 02:03 PM   #6
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,056
QuoteOriginally posted by A.M.92 Quote
That is strange with my K-7, the SR icon is completely disabled, i cannot access it, enable it at all, i have tried, green mode, AV, User, all modes, and it seems locked, just the icon and the red line over it appear, when i use the VF, i cannot see the icon light up. Do you mind without the lens, accessing the camera menu, and going to the menu where it has the option to enable.disable SR, is yours completely blocked and cant be accessed? In my camera SR function cannot be enabled at all.
Just tried it, lens off, power-up, enter lens focal length (50mm just to put something in), go to record menu pg 4. shake reduction and "input focal length" are both available.
This is in "P" mode. Did not bother trying other modes.

What drive mode is your camera in?.
10-23-2011, 03:21 PM   #7
Forum Member




Join Date: Jun 2010
Location: TX
Posts: 68
Original Poster
Hello, i have tried it in all modes, same result. I dont get how do you enter lens focal length without any lens attached? Record menu pg4 where is that located? Everytime i go to the menu to attempt to access Shake Reduction options enable/disable, it looks locked and cannot be scrolled down to be chosen.
10-23-2011, 04:17 PM   #8
Veteran Member




Join Date: Aug 2009
Photos: Gallery
Posts: 1,236
QuoteOriginally posted by A.M.92 Quote
Hello, i have tried it in all modes, same result. I dont get how do you enter lens focal length without any lens attached? Record menu pg4 where is that located? Everytime i go to the menu to attempt to access Shake Reduction options enable/disable, it looks locked and cannot be scrolled down to be chosen.
Is your camera in wireless remote mode or some other timer based mode? SR is disabled on some of those modes.

10-23-2011, 04:35 PM   #9
Forum Member




Join Date: Jun 2010
Location: TX
Posts: 68
Original Poster
No it is not, i have resetted the camera times, SR still unaccessable.
10-23-2011, 04:35 PM   #10
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,056
QuoteOriginally posted by A.M.92 Quote
Hello, i have tried it in all modes, same result. I dont get how do you enter lens focal length without any lens attached? Record menu pg4 where is that located? Everytime i go to the menu to attempt to access Shake Reduction options enable/disable, it looks locked and cannot be scrolled down to be chosen.
Power up camera and push menu button. Comes up with this screen. Page number 1. Use the four way controller to navigate to page 4.

Last edited by Ex Finn.; 11-11-2014 at 05:48 PM.
10-23-2011, 04:42 PM   #11
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,056
Since I am stupid and can not figure out how to separate images and text in uploads, on same page, here we go. A new reply.

After you get to the page 4, should looks like this. Then you should be able to make your selection. In this image the focal length is grayed out because of the DA 55-300 lens is attached.

Last edited by Ex Finn.; 11-11-2014 at 05:48 PM.
10-23-2011, 04:47 PM   #12
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,056
And none of this will be available if you are in a drive mode that does not support it. So that is why I asked what mode you are in.

Last edited by Ex Finn.; 11-11-2014 at 05:48 PM.
10-23-2011, 04:49 PM   #13
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,056
And if all this fails, you could have a problem with the camera.
Lets be clear, a shooting mode and a drive! mode are different animals,
Make sure you are in a DRIVE mode that allows SR.
10-23-2011, 06:31 PM   #14
Forum Member




Join Date: Jun 2010
Location: TX
Posts: 68
Original Poster
Thanks for all the hard work and help! Okay i get all that, but i dont have a lens attached to the camera, so i cannot do any of this, i am wondering does SR turn off automaticly when no lens is attached to the body? My SR worked fine with Lens before, but since i dont have a lens, i turned the camera on and just noticed that SR function in menu is completely unacessable it looks just as the "Imput focal lenght" you cannot scroll on to the Shake Reduction, at all, one user reported that the camera SR will not work when there is no lense attached, while another said, that it should work without lense, i am confused. I am not sure if my SR is not functoning. HAVE YOU TRIED SEEING IF SR IS ON, "WITHOUT" THE LENS ATTACHED TO THE BODY? I cant tell if SR is suppose to behave like that, since i dont have any lens with me currently, ( one is heading in for repairs) I get you tried it with the LENS, but without lens, do you mind posting a shot of the same menu but without the lens attached ?
10-23-2011, 06:35 PM   #15
Forum Member




Join Date: Jun 2010
Location: TX
Posts: 68
Original Poster
Btw, i am in Drive Mode.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-7, lens, pentax, pentax k-7, photography, sr
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 09:20 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top