Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-08-2012, 08:07 PM   #1
New Member




Join Date: Mar 2009
Location: Washington, USA
Photos: Gallery
Posts: 15
K20D won't turn on due to card door (?)

It started acting after I reinserted the card this morning. Taking off and putting back in the battery would start it but only if there was no card. Several cycles later it is not starting anymore, when turned on the battery symbol flashes on the top lcd for a second (or less if no card) then die. This happens without a card so I can discard that. I also tried a second, fully charged battery, without success. As I'm sure I'll be asked how I treat it - I bought it new and while I take good care of it, I don't back off from using it in rain, even blizzard; no falls or bumps though. Last weekend it accompanied me in a ski mountaineering outing and experienced some temperature variations but it performed just fine including afterwards.
I'm hoping someone else has seen this and maybe has a solution. I have no problem sending it to Cris for repair, but five bleak weeks without my trusty camera is a long time, even for this season. Many thanks for any suggestion.

02-08-2012, 08:15 PM   #2
Veteran Member
Sol Invictus's Avatar

Join Date: Aug 2011
Location: Calgary, Alberta
Photos: Gallery
Posts: 392
I had this happen to me when I left the card door open by accident. The battery indicator would flash on and disappear. I panicked for a minute before I realized what was going on. Once I closed the door the problem went away. So it definitely has to do with the card door.

My theory: some sort of contact between the door and body is not functioning properly and the camera thinks the door is open. I have no idea how to fix it beyond sending it in.

Sorry.
02-09-2012, 04:45 AM   #3
Moo
Senior Member




Join Date: Jun 2008
Posts: 174
In some of the older models, the door-open detection can be disabled from the debug menu. No idead if this includes the K20D, but it may be worth a try.
02-09-2012, 01:37 PM   #4
New Member




Join Date: Mar 2009
Location: Washington, USA
Photos: Gallery
Posts: 15
Original Poster
Update

I found the microswitch that's responsible for card door close signal. It's on the right of the clutch mechanism as seen from above, and the door steps on. After messing a bit with it, cleaning it with a brush and air blower, now it seems to be stuck on closed state and camera boots even with an open card door... Sadly this is not the end of it: while the camera starts and operates fine except it keeps displaying a card error message. Needless to say it happens with any card so there must be more than just a defective door contact. Today I'll pack it up and send it over to repairs.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, card, dslr, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-x won't turn on pmort Pentax DSLR Discussion 12 08-14-2012 07:48 PM
corrupted raw files due to sd card mtkang Troubleshooting and Beginner Help 12 11-01-2011 05:38 AM
K-2000 won't turn on. neongirl Troubleshooting and Beginner Help 5 01-30-2011 12:50 PM
My istD won't turn on ppickard Pentax DSLR Discussion 8 12-27-2010 11:10 AM
MZ-M LCD won't turn off knaff Pentax Film SLR Discussion 2 07-12-2010 04:30 AM



All times are GMT -7. The time now is 10:34 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top