Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-25-2006, 05:44 PM   #1
Junior Member




Join Date: Dec 2006
Posts: 36
K110D trouble!

hello everyone and merry christmas to all. now being christmas and all i have just received a brand new K110D slr pentax camera. the problem is that when i turn it on nothing comes up on the screen and when i press the shutter button it doesnt take a picture. the batteries are working because the menu option works, which is the only thing that does. the flash doesnt pop up as the manual says it should and i have gone through the whole operating manual and found nothing. it just wont take a picture. can this be fixed or is it a defect in the camera? any help is appreciated and thank you!

12-25-2006, 06:40 PM   #2
Ed in GA
Guest




QuoteOriginally posted by AmandaJL Quote
hello everyone and merry christmas to all. now being christmas and all i have just received a brand new K110D slr pentax camera. the problem is that when i turn it on nothing comes up on the screen and when i press the shutter button it doesnt take a picture. the batteries are working because the menu option works, which is the only thing that does. the flash doesnt pop up as the manual says it should and i have gone through the whole operating manual and found nothing. it just wont take a picture. can this be fixed or is it a defect in the camera? any help is appreciated and thank you!

I'd go back and recheck the batteries again.

If the Menu will come up, go to the "Set Up" portion, then to reset. Bring that up and do a complete reset. That May, or may not, work, but it's the only suggestion I have.

Ed
12-25-2006, 06:53 PM   #3
Site Supporter
slip's Avatar

Join Date: Oct 2006
Location: 2 hours north of toronto ontario canada
Photos: Gallery | Albums
Posts: 3,515
QuoteOriginally posted by AmandaJL Quote
hello everyone and merry christmas to all. now being christmas and all i have just received a brand new K110D slr pentax camera. the problem is that when i turn it on nothing comes up on the screen and when i press the shutter button it doesnt take a picture. the batteries are working because the menu option works, which is the only thing that does. the flash doesnt pop up as the manual says it should and i have gone through the whole operating manual and found nothing. it just wont take a picture. can this be fixed or is it a defect in the camera? any help is appreciated and thank you!
I would double check that the lens is "clicked in" properly. I would even take it off, then put it back on. of course I would leave the camera off while I was doing it.

good luck
12-26-2006, 08:59 AM   #4
Junior Member




Join Date: Dec 2006
Posts: 36
Original Poster
thank you! my lens was not on correctly. i took it off and read the instructions carefully as to how to put it on right. and it works! everythings ok! thank you very much.

12-26-2006, 09:29 AM   #5
Loyal Site Supporter




Join Date: Sep 2006
Location: Bronx NY
Photos: Gallery | Albums
Posts: 5,599
Yea and hooray! Too bad not all problems can be fixed so easily. Enjoy your new camera Amanda.

NaCl(hoping we'll see some of your pictures soon)H2O
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, christmas, dslr, k110d, photography, picture
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
SR trouble Mobben Troubleshooting and Beginner Help 7 03-23-2011 04:02 PM
SF1 trouble irishwhite Pentax Film SLR Discussion 8 03-23-2010 06:38 AM
Seem to be having trouble with focus jas Troubleshooting and Beginner Help 27 03-17-2010 01:55 PM
still having trouble with this lens Deiberson Troubleshooting and Beginner Help 4 12-27-2009 02:44 PM
Error Trouble logging in slowpez Site Suggestions and Help 5 10-25-2009 08:13 AM



All times are GMT -7. The time now is 09:18 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top