Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-07-2012, 12:15 PM   #1
Veteran Member
GabrielFFontes's Avatar

Join Date: Jul 2011
Location: Rio de Janeiro, Brazil
Posts: 647
Pentax K-30 debug mode

Hi guys!
I just got my K-30 this morning, and i've been trying my defective (at least with the K-r) Sigma 70-200 2.8
The adjustment seems to be fixed now (i mean constant throughout the range), but it seems like it would require a -14 or something like that.
Using my K-r, that would be easy to do, using the debug mode, but how can i do this with a K-30?
Is there any way to activate it?
(Pktether doesn't work)
Thank you

10-07-2012, 04:42 PM   #2
Site Supporter




Join Date: May 2012
Location: Adelaide
Photos: Gallery | Albums
Posts: 1,081
My understanding is that focus adjustment is a standard menu item in the K-30 and a debug program is not required. Also, focus adjust can be done lens by lens and not a single global adjustment like the K-x/K-r.
10-07-2012, 04:51 PM   #3
Veteran Member
GabrielFFontes's Avatar

Join Date: Jul 2011
Location: Rio de Janeiro, Brazil
Posts: 647
Original Poster
QuoteOriginally posted by southlander Quote
My understanding is that focus adjustment is a standard menu item in the K-30 and a debug program is not required. Also, focus adjust can be done lens by lens and not a single global adjustment like the K-x/K-r.
Yes, it is a standart menu option, but it only allows -10 to +10...I wanted at least -15, and that would only be possible using debug :/
10-07-2012, 09:12 PM   #4
Site Supporter




Join Date: May 2012
Location: Adelaide
Photos: Gallery | Albums
Posts: 1,081
QuoteOriginally posted by GabrielFFontes Quote
Yes, it is a standart menu option, but it only allows -10 to +10...I wanted at least -15, and that would only be possible using debug :/
I'm not sure if the adjustment scale in the menu option is the same as that employed in the debug program, ie is +5 in the menu option the same as +50 in the K-x/K-r debug mode? Can someone with a K-30 or K-5 chime in here to confirm or deny??

10-08-2012, 01:06 AM   #5
Veteran Member
GabrielFFontes's Avatar

Join Date: Jul 2011
Location: Rio de Janeiro, Brazil
Posts: 647
Original Poster
QuoteOriginally posted by southlander Quote
I'm not sure if the adjustment scale in the menu option is the same as that employed in the debug program, ie is +5 in the menu option the same as +50 in the K-x/K-r debug mode? Can someone with a K-30 or K-5 chime in here to confirm or deny??
Well, on a K-r, a -10 in the menu would equal -100um using debug mode...the scale is probably unchanged.
10-08-2012, 04:57 AM   #6
Site Supporter




Join Date: May 2012
Location: Adelaide
Photos: Gallery | Albums
Posts: 1,081
So when you say -14, that translates to -140um? That seems a pretty big adjustment to me and probably would mean when you change lenses, the next lens could be be way off (as the debug adjustment is global and applies to all lenses). I can use debug in the field as I leave the required code on my SD card at all times, but I find I forget to use it in the heat of the moment rapidly switching lenses and end up with less that optimal images on the second lens I am using . You might want to think about getting the Sigma re-calibrated if it is that far out.
10-08-2012, 05:09 AM   #7
Veteran Member
GabrielFFontes's Avatar

Join Date: Jul 2011
Location: Rio de Janeiro, Brazil
Posts: 647
Original Poster
QuoteOriginally posted by southlander Quote
So when you say -14, that translates to -140um? That seems a pretty big adjustment to me and probably would mean when you change lenses, the next lens could be be way off (as the debug adjustment is global and applies to all lenses). I can use debug in the field as I leave the required code on my SD card at all times, but I find I forget to use it in the heat of the moment rapidly switching lenses and end up with less that optimal images on the second lens I am using . You might want to think about getting the Sigma re-calibrated if it is that far out.
I will call a guy that recalibrates Sigma lenses here.
Might be too expensive :/
And yes, -14 means -140um
I have this lens but it's not mine yet. The seller isn't a Pentax user anymore, so he said i could have the lens without paying to try to solve the problem, and if i can solve it, i will pay.
If i can't solve, i can just return it.
10-29-2012, 04:17 AM   #8
Senior Member




Join Date: Jan 2008
Location: Chennai, India
Photos: Albums
Posts: 226
Hi. Could you please tell me the modset file name for K-r? Thanks

10-29-2012, 06:01 AM   #9
Veteran Member
GabrielFFontes's Avatar

Join Date: Jul 2011
Location: Rio de Janeiro, Brazil
Posts: 647
Original Poster
QuoteOriginally posted by siva.ss.kumar Quote
Hi. Could you please tell me the modset file name for K-r? Thanks
Hi Siva!
If i were you, i would download pktether.
Download this software, connect your camera via USB and then go to "Debug mode on" option there.
10-29-2012, 09:32 AM   #10
Senior Member




Join Date: Jan 2008
Location: Chennai, India
Photos: Albums
Posts: 226
Thanks. It was for a friend who had misplaced his USB cable. Hence my question.
Anyways, for now he needs only the focus adjust and is using the custom menu option.
03-11-2013, 06:32 PM   #11
Forum Member




Join Date: Mar 2013
Location: Middle of Siberia
Photos: Gallery
Posts: 93
QuoteOriginally posted by GabrielFFontes Quote
Pktether doesn't work
With the latest firmware installed, Pktether in fact does work with K-30.
I could switch the camera into debug mode for AF adjustment.
03-11-2013, 08:37 PM   #12
Pentaxian
MegaPower's Avatar

Join Date: May 2010
Location: Hong Kong / Irvine, CA
Photos: Gallery | Albums
Posts: 561
apply all -4
apply one -10

You get -14 in total.

BTW, I would like to know the file to activate debug mode on K30, too.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, debug, dslr, k-30, k-r, mode, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax k-5 Debug mode eigelb Pentax K-5 38 06-09-2014 01:58 AM
K 10 stuck on debug mode graveyardeyes Troubleshooting and Beginner Help 4 08-15-2011 12:09 PM
Debug Mode a johnson Pentax DSLR Discussion 7 08-15-2011 07:17 AM
K-x debug mode w/pics please mlatour Troubleshooting and Beginner Help 9 01-26-2011 11:26 AM
How to access Debug Mode of Pentax K200 Thareen Pentax DSLR Discussion 28 04-08-2010 01:39 PM



All times are GMT -7. The time now is 07:46 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top