Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-09-2008, 07:28 AM   #1
New Member




Join Date: Feb 2008
Location: UK
Posts: 1
K10D focus problem

Hi,

I bought a K10D a couple of months ago and for the most part, I'm very happy with it.

However, as I have continued to use it, I've noticed that on occasions I get a run of three to four shots that are all out of focus. Not just that the focus falls elsewhere in the shot, but that nothing in the shot is in focus, even at high shutter speeds and in good light.

From all of the reviews I've read, along with people's comments in this forum, it doesn't seem to be something that is generally flagged up and having owned other DSLRs in the past, wasn't something I was expecting.

I've noticed that the camera also seems to miss/back focus on a regular basis, particularly with the Sigma 70-300mm I have, where focussing on a subject, say 200 yards away at 300mm will leave the focus point around 20 yards behind the subject, even in good light and with good subject contrast and using the single centre focus point. I realise that the K10d does suffer from front/back focus problems but hadn't expected it to be to such a degree.

Do I have a faulty camera? I have spoken to the retailer but they have said that they would have to send the camera off for repairs, which could take four weeks; I'm not happy at losing a 2 month old camera for that period of time, particularly when I need it on a daily basis for my photography degree.

Anyone any ideas?

Chris

02-09-2008, 12:36 PM   #2
Veteran Member
offertonhatter's Avatar

Join Date: Jul 2007
Location: North West UK
Posts: 384
It seems that indeed that it might be faulty. I have had my K10D for nearly 12months and no problems at all. Go back to your retailer and discuss further and take some examples with you, It might need to go back for repair. As it is less than 12 months old you should have the repair / replace for free. Ask them (if they are reputable, for a loan camera for the period of repair)
02-13-2008, 12:01 AM   #3
Senior Member
marcdsgn's Avatar

Join Date: Dec 2007
Location: Queensland
Photos: Gallery
Posts: 265
Might be just a simple case of the lens' electronic contacts not quite touching...

When I first got my K10D body, it wouldn't register focus or metering after I first put the lens on. After frantic consultation with the manual cover-to-cover to no avail, I tried removing the lens and putting it back on. Lo and behold it worked perfectly - mustn't have twisted it quite enough when I first put it on (even though I heard it "click").
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, degree, dslr, focus, k10d, light, photography, shot, subject, yards
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D and focus problem cherno Pentax DSLR Discussion 10 10-10-2010 09:09 PM
Manual focus problem with K10D? yyyzzz Pentax SLR Lens Discussion 8 12-01-2009 05:50 AM
K10D focus problem... (again) Nuutti Pentax DSLR Discussion 2 06-25-2008 03:38 PM
K10D auto focus problem? Tom C Pentax DSLR Discussion 18 05-08-2008 01:13 AM
K10D Back-focus problem... TomInJax Pentax DSLR Discussion 35 04-24-2008 11:27 AM



All times are GMT -7. The time now is 11:12 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top