Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-15-2008, 11:58 AM   #1
Senior Member




Join Date: Dec 2006
Location: Vancouver BC
Posts: 230
K10D Aperature Dial

I normally shoot in AV mode. Not always sure why that is my preference but it is. Anyway this is about my K10D with grip, and the body's rear e dial. It seems that periodically the rear e dial (aperture) does not want to cooperate with my desires to increase or decrease from a particular setting. If I spin the grip's e dial for aperture it works and then the body's e dial will work. If I'm in another setting such as manual and it happens I can spin/jog the shutter then go back to the aperture. Sometimes if I just wiggle and fiddle it will be good to go or if I turn off and on. It seems very intermittent and as it happens when I am trying to get a capture I don't really want to spend too much time on the problem, I just want it gone so I can get the shot before it's gone. When I do have time to be more methodical it never seems to arise.

My question has anybody 'sperienced anything like this, and if so is/was it bad contact(s) on the dial requiring a service centre visit?

In the mean time I'm gonna carve out some time to spend trying to replicate the problem and then systematically see what it takes to get it to go away. A couple times it happened I thought I was just imagining a problem.

Thanks,
John


Last edited by jnorth; 02-15-2008 at 11:59 AM. Reason: yes the title has a spelling error arghh
02-15-2008, 12:15 PM   #2
Forum Member




Join Date: Oct 2007
Location: Oklahoma
Photos: Gallery
Posts: 68
I would think the most likely time for this to happen would be where the light is marginal for the f-stop you are trying to use in conjunction with the aperture. If you are in Av mode, the aperture is the first thing to set. The camera will then decide upon shutter speed and ISO (unless you have the ISO locked to one value).

I think about the only way to determine what's going on is to get outside in some consistent light with plenty of exposure latitude, and then do a process of elimination. If you turn the camera off, it resets the aperture value, so that's what's allowing your change in that case. But if you keep the camera on, and are in Av mode, and set your desired aperture, it should stay at that aperture setting until you intentionally change it. Something else that may be happening if you're using the grip is that the ball of your hand may be hitting the green button while you're holding the camera. Then everything resets to what the camera considers the best value (at least that's how I remember it). When I first got the grip, I had that problem a lot - my hands are just the right size to create a "green button hazard" on the grip.

Good luck,
Barry
02-15-2008, 06:09 PM   #3
Veteran Member
-=JoN=-'s Avatar

Join Date: Nov 2006
Location: NYC
Posts: 1,000
it's a grip thing. sometimes the grip e-dial or the body e-dial gets stuck in the middle. i get that quite often. I've learned to just spin both dials quickly if anything. does the same thing on the front e-dial.

take off the grip..and it's all good.....(I shoot mostly in M mode..so it's twice the fun for me...)
02-15-2008, 07:45 PM   #4
Junior Member




Join Date: Jan 2008
Location: Missouri, USA
Posts: 25
Maybe this sounds stupid, or very, very basic, but have you checked and double checked that the grip on/off switch is on?

I must be an idiot, but when I first got my grip, I didn't know why it wouldn't work.

Duh, I didn't turn the bottom power switch on.

Just saying.....

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, camera, dslr, k10d, photography, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mode dial problem on K10d Plornt Pentax DSLR Discussion 13 03-16-2011 10:46 PM
Faulty k10d mode dial Northern Soul Pentax DSLR Discussion 21 10-26-2010 02:05 AM
K10D e-dial weirdness brothereye Pentax DSLR Discussion 15 05-07-2008 05:13 AM
Rear e-dial stuck on K10D Groundloop Pentax DSLR Discussion 11 03-14-2008 11:22 AM
K10D and aperature ring setting WildSioux Pentax DSLR Discussion 2 03-20-2007 09:49 PM



All times are GMT -7. The time now is 02:39 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top