Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-17-2008, 02:08 PM   #16
Junior Member
Lensvision's Avatar

Join Date: Feb 2008
Location: The Netherlands
Photos: Gallery
Posts: 47
Could it be a memorycard problem instead of a camera problem?

02-17-2008, 05:55 PM   #17
Veteran Member




Join Date: Sep 2006
Photos: Gallery
Posts: 5,713
Good point Lensvision, a different memory card is probably the first thing that we should all try when experiencing picture problems.

And don't use a cheap e-bay special. There's a good chance that it's a fake, often faulty.
02-17-2008, 06:19 PM   #18
Veteran Member
Pentax_XTC's Avatar

Join Date: Jan 2008
Location: Duluth, GA
Posts: 365
Original Poster
I bought 2 Kingston 4GB Class 6 cards from B&H. It does it on both of them. Now it's not giving me the green, now it just takes a black photo. again if I turn it off then back on it fixes it. I guess I'm returning it to B&H. I just hate that I've been waiting since June to get the money to buy it, and now I have to wait to get another one. To sum it all up... This just sucks.
02-17-2008, 07:59 PM   #19
Veteran Member




Join Date: Jun 2007
Location: Buffalo/Rochester, NY
Photos: Albums
Posts: 1,133
It sucks, and I know how you feel, but unless you have a great reason to hold off sending it in (like you have a critical gig and can't do without hacing a camera for several weeks), I would send it in right away. From what you're describing the problem isn't getting any better.

I agree with others here, the longer you wait, chances are the worse or more permanent it will become.

Now, if you bought it within a couple of days, B&H might send you a new one. If it's been a few months, you're going to have to send it to Pentax.

02-17-2008, 10:03 PM   #20
Veteran Member




Join Date: Sep 2006
Photos: Gallery
Posts: 5,713
QuoteOriginally posted by Pentax_XTC Quote
I bought 2 Kingston 4GB Class 6 cards from B&H. It does it on both of them. Now it's not giving me the green, now it just takes a black photo. again if I turn it off then back on it fixes it. I guess I'm returning it to B&H. I just hate that I've been waiting since June to get the money to buy it, and now I have to wait to get another one. To sum it all up... This just sucks.
I'd still contact B&H, and tell them your sending it in.
Ask them to set a camera aside for you until yours arrives.

With it becoming harder and harder to get the K10 you sure don't want them selling their last copy
02-17-2008, 11:24 PM   #21
Veteran Member
Pentax_XTC's Avatar

Join Date: Jan 2008
Location: Duluth, GA
Posts: 365
Original Poster
OK. I agree this has to be fixed. I received the camera last Tuesday, 02/12 @ 8:32pm from UPS. I can either pay to have it shipped back to B&H in New York or I can take it to a Pentax authorized service center that happens to be only 6 miles from me and pay nothing.

Has anyone used CRJ (Camera Repair Japan, Inc) in Duluth, GA? I found them through the Pentax website as a service center to send warranty products.

I have nothing against B&H. But, if it can be fixed locally without me spending more money on shipping (I have a wife & kids you know), then I think that might be my better option.

So now I ask... Which would you do?...
02-18-2008, 04:33 AM   #22
Veteran Member




Join Date: Dec 2007
Location: Jacksonville, FL
Photos: Gallery
Posts: 531
If it was me, I would exchange it with B&H ASAP. At least this way if the repair center cannot find the issue, you won't be stuck with an intermittent problem for the next few months.

It will be worth it in the long run. Sometimes it is better to replace it than repair it.
02-18-2008, 04:36 AM   #23
Inactive Account




Join Date: Jan 2008
Location: Portland, Maine
Posts: 218
I would try to get a new one from B&H. If they won't give you a new one then you should see if you can just return it and get a new one from somewhere else. I just got an email from Abe's of Maine that shows they are on sale so they may still have them. At the very worst I guess I would bring it to the authorized service center 6 miles away.

02-19-2008, 04:12 AM   #24
Veteran Member




Join Date: Jan 2008
Location: Seattle, Washington, USA
Photos: Gallery
Posts: 813
In general, it is best to first contact the vendor where you bought the product you suspect is faulty; I'd give B&H a call and talk to their service department. Detail your experience and ask if you should return it for replacement. Get an RMA (Return Merchandise Authorization) number and follow their return procedures if they agree to a return for inspection and possible replacement. If the vendor won't cooperate, then is the time to contact the manufacturer's warranty service department. They may tell you to send it in to the national center in Colorado, or may refer you to a regional authorized warranty service center.
02-19-2008, 10:09 AM   #25
Inactive Account




Join Date: Jan 2008
Location: Portland, Maine
Posts: 218
A few years ago I bought a brand new Nissan 360Z. As soon as I got it home when I was waxing it I found a dent in a lower front body panel that was not noticable unless you really looked for it. The car had 18 miles on it. I immediately called the dealer and told them about the dent. They assured me that they would fix the problem to my satisfaction. I brought the car in and the service manager told me they would fix the dent with body filler. I told him I wanted a new body panel. He refused. I told him I either wanted a new car without any body damage or to just cancel the deal.

They ended up refunding me my money and I bought a Corvette.

If the product is only a few weeks old and has problems like that its best to just get a brand new replacement.

Last edited by Sprags; 02-19-2008 at 01:34 PM.
02-19-2008, 01:37 PM   #26
Veteran Member
Tom M's Avatar

Join Date: Aug 2007
Location: Lincoln Park, NJ
Photos: Gallery
Posts: 782
Oh, this should be good - Let's see how B&H handles this..

Where for art thou Henry P?
02-19-2008, 02:03 PM   #27
Forum Member
ballgofar's Avatar

Join Date: Jan 2008
Location: Rochester, NY
Posts: 87
Going along with that memory card theory...

Try reformatting the memory cards. You know, go into the SET-UP menu, select FORMAT, and DELETE ALL DATA (make sure you've save all your pictures first).

It's worth a shot. This happened to me before, and formatting it solved everything.
02-19-2008, 10:14 PM   #28
Veteran Member
Pentax_XTC's Avatar

Join Date: Jan 2008
Location: Duluth, GA
Posts: 365
Original Poster
I reformatted the memory cards already and still the same thing.

I called B&H and got an RMA #. Luckily, they are letting me keep it until next week so I can take pictures of my son's birthday party this weekend. (Hence the reason I didn't want to give it up so quickly.) I hate to be without it, but i guess even the best company has 1 or 2 bad units on occasion. I'll post some photos soon. I'm just trying to decide on Photoshop Elements vs. Bibble Pro right now for RAW conversion and minor post processing.

Last edited by Pentax_XTC; 02-20-2008 at 06:30 AM.
03-05-2008, 09:26 PM   #29
Veteran Member
Pentax_XTC's Avatar

Join Date: Jan 2008
Location: Duluth, GA
Posts: 365
Original Poster
Yep it was. B & H did me right though. Paid for the shipping back to them and the shipping for the new K10D to me! I will have to use them again for my next purchase. At least I am now happy again with a K10D in my hands I lucked out too that the viewfinder on this one is aligned great as well.

Thanks to everyone for your posts. I hated to be without it, but I think I'l be happier in the future now.
03-05-2008, 11:45 PM   #30
Veteran Member




Join Date: Sep 2006
Photos: Gallery
Posts: 5,713
That's great news, thanks for sharing it with us
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, photography, pictures, power
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello from Houston with broken K10D tomballpentax Welcomes and Introductions 5 10-11-2010 12:35 PM
My broken K10d jajajab Pentax DSLR Discussion 3 10-30-2009 05:02 AM
My K10D is broken........ Sila Pentax DSLR Discussion 4 03-04-2009 04:21 PM
Is my K10d broken too? pasipasi Pentax DSLR Discussion 12 09-27-2008 02:55 AM
Help! K10D AF broken? yenemy Pentax DSLR Discussion 5 07-01-2008 03:19 PM



All times are GMT -7. The time now is 01:05 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top