Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-07-2007, 06:13 PM   #1
Senior Member




Join Date: Jan 2007
Location: Phoenix, AZ USA
Posts: 165
AF360FGZ Problem

Hi, new guy here with a flash problem. I have a new AF360AF for my istDS and am unable to change from M zoom to A zoom and "24mm" continues to flash on the LCD. It happens off the camera or on the camera with any lens. The only things I can change are the mode and flash compensation

I posted this question on another forum and one person was kind enough to respond indicating that I have a defective unit. I would appreciate any feedback or suggestions. Thanks for any help you can offer.

01-07-2007, 07:01 PM   #2
Pentaxian




Join Date: Sep 2006
Location: Kaunas
Posts: 1,452
Do you hear beep when switch flash on?
01-07-2007, 07:41 PM   #3
Site Supporter
Site Supporter




Join Date: Sep 2006
Location: midwest, United States
Photos: Gallery
Posts: 3,340
Don't have a 360 in front of me but a couple thoughts came up. First check the batteries. I borrowed a 360 and used rechargeable batts. Some functions would work fine others were just weird. Try flash with some new alkaline batts. I haven't seen a flash act this strange in ages. Was ready to send it in for repair.
There is a switch on the right side of the flash (looking at the back of it) that has white and yellow markings. Can't remember if it has to be in white to allow setting manual/ auto zoom or not. It allows Pentax to use buttons for more than 1 function. Check it.
Also won't auto zoom with lenses that are A or earlier because there isn't anything in the lens to report focal length. Thankfully Pentax allows manual setting for these lenses. I have an older Sigma ttl flash that doesn't. Auto only.
You don't have the little pull out diffuser over the flash lens do you? That overides the auto zoom because it is only used for wideangles. It is easy to miss this. Hope this works.
If all else fails call Pentax and talk to a technician. There are nice helpful people. They may think of something we have missed.
thanks
barondla
thanks
barondla
01-07-2007, 10:15 PM   #4
Senior Member




Join Date: Jan 2007
Location: Phoenix, AZ USA
Posts: 165
Original Poster
Thanks for the responses.

When powering up, I hear a buzz or hum rather than a beep.

The format swith is set in white in accordance with the manual and the format is 35mm.

The AA batteries were/are fresh and the diffuser was not over the flash. The fact that I can only be in the M zoom even when the flash unit is off the camera and that it makes no difference what kind of lens is attached is making me think that is defective. I will call Pentax tomorrow.

Thanks again for the responses.

01-08-2007, 11:22 PM   #5
Xgear
Guest




If the flash unit makes a buzz noise and the LCD screen is blank during startup your zoom motor in the flash is stuck. It will finally start up but will not go into auto mode. The normal operation for start up in hot shoe is you hear the zoom motor in the flash move and the LCD screen comes on at same time it is fast. It starts in auto mode. I know this sounds weird but you can do what I did and and give it a good swift bump and knock it loose. It works fine on my K10. just make sure before warranty is up right. Got good deal from Amazon $197.94 with $50 gift card $25.00 rebate and free shipping.
One thing, it is hard to mount and remove from body.


See the catchlight in eyes?
Attached Images
 
01-09-2007, 10:37 AM   #6
Senior Member




Join Date: Jan 2007
Location: Phoenix, AZ USA
Posts: 165
Original Poster
XGear: Thanks for the reply. I get about a 5 second buzz before the LCD comes on with M zoom and "24mm" continously flashing. I smacked it around several times as you suggested but it did not change any thing.
I also got the unit from Amazon at the same price. It sounds like you had a similar problem. Amazon is sending a replacement unit but I hope their entire stock of these is not defective. I will post the results of the new unit when I get it.
01-09-2007, 12:37 PM   #7
New Member




Join Date: Nov 2006
Location: ca
Posts: 6
me too

I bought the 360 at adorama couple of months ago and it was working but the zoom made a huge racket moving one way. it would operate properly as it stepped into greater zoom but when it went into "return to beginning" it sounded like it was grinding gears.

maybe pentax is not detecting motor problems on these flashes
01-09-2007, 02:51 PM   #8
Senior Member




Join Date: Jan 2007
Location: Phoenix, AZ USA
Posts: 165
Original Poster
AdamR: Were you able to get it repaired or exchanged or are you just living with it?

01-11-2007, 07:31 PM   #9
Senior Member




Join Date: Jan 2007
Location: Phoenix, AZ USA
Posts: 165
Original Poster
Just got the replacement flash from Amazon. I contacted Amazon by phone on Mon., 1/7 and received the replacement today, Thurs., 1/11. I think that's pretty good service. Anyway, it works as it should in A zoom default and results in great exposures. It even works with the 50mm, 1.4 M lens with the camera set on manual. The built in flash on the DS blows the picture away with the M lens.
Much thanks to all who replied.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, change, dslr, flash, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
AF360FGZ Problems calicojack Flashes, Lighting, and Studio 7 03-01-2011 05:41 PM
Problem with AF360FGZ and K100D on P-TTL Yarf Flashes, Lighting, and Studio 3 09-02-2008 07:31 PM
K100D and AF360fgz problem zorobabel Flashes, Lighting, and Studio 13 05-02-2008 03:12 PM
Problem with AF360FGZ on K20D foots Pentax DSLR Discussion 2 04-21-2008 06:59 PM
AF360FGZ and K10D problem boxcam78 Pentax DSLR Discussion 1 11-03-2007 02:42 PM



All times are GMT -7. The time now is 04:58 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top