Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-15-2013, 03:14 AM   #1
Veteran Member




Join Date: Dec 2009
Location: Perth
Photos: Albums
Posts: 371
My Camera is still broken

This is mostly a grumble because I was really looking forward to going out with my K-5 this weekend and now I can't.

My K5 has been underexposing in Av mode by 2 stops for as long as I remember, never really bothered me because it forced me to use manual mode more and I could always bump the 2 stops in lightroom if I needed Av mode.

Anyway a few weeks ago my not quite two yr old son ninja'd his way into my bedroom where my K-5 was on the bed and threw it on the ground breaking the thread where the bottom mounting screw fixed to. I put the mount back together but it was not quite right.

So I sent it to CR Kennedy (the Aus importer) for repair, telling them of the mount. When they emailed me with the quote for beginning I told them that I thought there was an issue maybe with the light meter or something akin to that because Av mode underexposed by 2 stops and has done since before the camera being thrown(possibly others but I never use them) so could they check it out while they were fixing it. The CR guy informed me there was nothing they could do until the mount was fixed so I gave the go ahead and asked if they could check the Av mode issue after it was done. Got the invoice, paid it and it arrived today.....

Guess where its going tomorrow, yep, right back again. Mount is good, light meter not so much. Av mode is stuck at 1/8000 shutter speed even at f1.8 and iso 12800. All the modes including green mode take a nice black photo. Surely they put a lens on the camera and took a test shot, surely, because they updated the firmware. Maybe something come loose in the post.

And now I will miss another weekend of shooting. Well, I'll be shooting film but that's not the point, I am still sad.

04-15-2013, 03:38 AM   #2
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 31,511
This is an ideal opportunity to have to purchase a K-5 IIs as a back body for just such occasions, no one could argue against that.
04-15-2013, 03:50 AM   #3
wjt
Veteran Member




Join Date: Dec 2009
Location: Perth
Photos: Albums
Posts: 371
Original Poster
Haha, im actually waiting to see the outcome of the FF saga from Pentax before I buy anything else.

Ive used that logic before, finance minister added the war ministry to her portfolio a few months later when she realised... I figured being as the K7 and K5 looked the same she would never know
04-15-2013, 03:56 AM   #4
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 31,511
QuoteOriginally posted by wjt Quote
she would never know
So it was a "fit up" then.

Who did you tell?

04-15-2013, 06:37 AM   #5
Veteran Member




Join Date: Jun 2011
Location: Utah
Posts: 339
wjt... I'm a little confused. If the aperture is wide-open and the ISO is jacked up, why wouldn't it opt for the fastest shutter speed?
04-15-2013, 06:43 AM   #6
Senior Member




Join Date: May 2012
Photos: Gallery
Posts: 140
Sell the son.

Blood be damned. Nobody breaks my toys.
04-15-2013, 06:56 AM   #7
Loyal Site Supporter




Join Date: Jun 2009
Location: Tumbleweed, Arizona
Photos: Gallery | Albums
Posts: 5,048
QuoteOriginally posted by wjt Quote
Haha, im actually waiting to see the outcome of the FF saga from Pentax before I buy anything else.

Ive used that logic before, finance minister added the war ministry to her portfolio a few months later when she realised... I figured being as the K7 and K5 looked the same she would never know
I have to remember that one. I have been dealing with the Chancellor of the Exchequer, who is now assuming the Office of the Obscure.

04-15-2013, 07:16 AM   #8
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
Separate PP account. Also, Ministers come and go, but those of us in the trenches remain.

04-15-2013, 07:35 PM   #9
Veteran Member




Join Date: Mar 2007
Location: Boston, PRofMA
Photos: Albums
Posts: 3,053
QuoteOriginally posted by wjt Quote
The CR guy informed me there was nothing they could do until the mount was fixed so I gave the go ahead and asked if they could check the Av mode issue after it was done. Got the invoice, paid it and it arrived today.....
How much did that cost?
Usually, repairs to electronics nowadays aren't worth it given how fast stuff gets outdated
04-16-2013, 04:03 AM   #10
wjt
Veteran Member




Join Date: Dec 2009
Location: Perth
Photos: Albums
Posts: 371
Original Poster
It only cost $160 all up including shipping back to WA. Quite reasonable for the mount repair, which I was slightly sad about to be honest. I was kinda hoping it was a write off so I could get a new one.
04-17-2013, 12:37 AM   #11
Site Supporter




Join Date: Nov 2010
Location: Johannesburg
Photos: Albums
Posts: 159
Here's something to check. I had a similar problem this morning. I found my exposure compensation all the way down at -5. This meant the camera was trying to do fastest shutter speed at highest ISO.......

Once I reset it to 0 I was fine. I had been taking pictures of the moon with a 500mm lens and had to cut down the exposure to get the detail on the surface.
04-17-2013, 08:37 AM   #12
Veteran Member




Join Date: Mar 2007
Location: Boston, PRofMA
Photos: Albums
Posts: 3,053
QuoteOriginally posted by wjt Quote
It only cost $160 all up including shipping back to WA. Quite reasonable for the mount repair, which I was slightly sad about to be honest. I was kinda hoping it was a write off so I could get a new one.
Not bad at all.
Canon users who have had that happen get charged $400
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
av, camera, check, cr, dslr, k-5, light, meter, mode, mount, photography, weekend
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this lens or camera broken? (sample pics) heartx3jess Troubleshooting and Beginner Help 12 10-28-2012 02:12 AM
My camera is almost the size of my toaster with my D-BG4 Battery Grip disco_owner Pentax Camera and Field Accessories 24 05-09-2012 12:44 AM
Is the K-10 still a good camera or is it outdated? PentaxianBear Pentax DSLR Discussion 50 12-15-2011 02:47 AM
effects filters slow down camera,turn off filter and camera is still slow zorak Pentax K-r 7 10-05-2011 06:12 AM
My K100ds is broken pasipasi Pentax DSLR Discussion 5 10-06-2008 12:28 PM



All times are GMT -7. The time now is 05:17 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top