Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-30-2008, 03:16 PM   #1
Site Supporter




Join Date: Mar 2008
Location: placerville, ca
Photos: Gallery | Albums
Posts: 170
help sigma 50-500

EEEEEEEEEEEEEEEEEEEEEEK!!!
Just got this thing, and now it won't autofocus. For about the first 30 shots or so, everything seemd ok, now it is all but dead as an af lens. Took it off the K10D to see if it was the camera body. Thankfully, the lens does not work on my K100D either.
Any help would be greatly appreciated.
Jack

03-30-2008, 03:42 PM   #2
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,144
QuoteOriginally posted by pntxjack Quote
EEEEEEEEEEEEEEEEEEEEEEK!!!
Just got this thing, and now it won't autofocus. For about the first 30 shots or so, everything seemd ok, now it is all but dead as an af lens. Took it off the K10D to see if it was the camera body. Thankfully, the lens does not work on my K100D either.
Any help would be greatly appreciated.
Jack
Carefully clean the electrical contacts on the lens mount with alcohol and a lint free cloth.

Make sure that there is not a manual focus switch on the lens that you have inadvertently moved. Some lenses have a switch that operates by pushing/pulling the focus ring - most Pentax FA lenses, for example. I am not familiar with the Bigma, but it might use a similar system.
03-30-2008, 04:04 PM   #3
BPT
Veteran Member




Join Date: Jul 2007
Location: Fruitvale, British Columbia Canada
Photos: Gallery
Posts: 310
QuoteOriginally posted by Canada_Rockies Quote
Make sure that there is not a manual focus switch on the lens that you have inadvertently moved. Some lenses have a switch that operates by pushing/pulling the focus ring - most Pentax FA lenses, for example. I am not familiar with the Bigma, but it might use a similar system.
This is probably it, the sigma 50-500 ring has a MF and AF position grab the focus ring and push forwards to the AF position
03-30-2008, 04:23 PM   #4
Veteran Member
-=JoN=-'s Avatar

Join Date: Nov 2006
Location: NYC
Posts: 1,000
i had a problem w/ my sigma 28mm ex dg...it was like that tho out of the box. if it's still under warranty, contact sigma themselves. they have a very good support team....

the problem w/ my lens was a bad board (according to the service slip)

03-30-2008, 05:50 PM   #5
Veteran Member
palmor's Avatar

Join Date: Dec 2006
Location: North of Boston, MA
Posts: 798
The same thing happened recently to my 70-200EX lens, does the AF sound like its tring to do something but it doesn't? That is what happened to mine and it is costing me about $130 to fix (it is still at Sigma as we speak).

Good luck

John
03-30-2008, 08:08 PM   #6
Site Supporter




Join Date: Mar 2008
Location: placerville, ca
Photos: Gallery | Albums
Posts: 170
Original Poster
Canada Rockies, BPT, John, and Jon--
Thank you all.
I will try the cleaning the contacts, but the lens is brand new so I doubt that is the problem.
John, that is exactly the problem. At first (yesterday afternoon), I could keep pressing half way on the shutter release adn eventuall, bit by bit, it would auto focus. Today it tries and tries, but just can't get there. I am VERY disappointed that Sigma could produce such a dog, or at least that they could let such a dog get past their quality control. On the plus siide, it is still under warranty. I had only one other sigma lens, the 70-200 f2.8. Never used it. Just sold it on eBay for very nearly twice what I paid for it Yahooooo! I hope this quality issue is unique to my lens. Does sigma have a rep for poor quality?
Thanks again.
Jack
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, help, lens, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
IQ Takumar 500 f/4.5 vs Sigma 170-500 KevinR Pentax SLR Lens Discussion 1 10-11-2010 09:51 AM
SIgma 50-500 or 150-500 mikejustice Photographic Technique 1 12-18-2009 01:55 PM
Sigma 50-500 vs 150-500 vs 170-500 juanraortiz Pentax SLR Lens Discussion 19 10-30-2009 03:32 PM
Sigma lenses 150-500, 50-500 ? lesmore49 Pentax SLR Lens Discussion 19 03-21-2009 06:49 AM
Sigma 175-500 vs Bigma 50-500 VAV Pentax SLR Lens Discussion 2 07-04-2008 01:24 PM



All times are GMT -7. The time now is 05:32 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top